summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-01 22:07:29 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-01 22:07:29 +0000
commit83bdd237e9efb221b07365d5658aa6ccf3468c72 (patch)
tree4da08f33e12725623732045184ab88452a8b0f50 /dev-util/lincvs/lincvs-1.2.0.ebuild
parentVersion bumped. Closes #23568 (diff)
downloadhistorical-83bdd237e9efb221b07365d5658aa6ccf3468c72.tar.gz
historical-83bdd237e9efb221b07365d5658aa6ccf3468c72.tar.bz2
historical-83bdd237e9efb221b07365d5658aa6ccf3468c72.zip
Version bumped. Closes #23568
Diffstat (limited to 'dev-util/lincvs/lincvs-1.2.0.ebuild')
-rw-r--r--dev-util/lincvs/lincvs-1.2.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/lincvs/lincvs-1.2.0.ebuild b/dev-util/lincvs/lincvs-1.2.0.ebuild
new file mode 100644
index 000000000000..c248e098c638
--- /dev/null
+++ b/dev-util/lincvs/lincvs-1.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/lincvs-1.2.0.ebuild,v 1.1 2003/07/01 22:07:20 mholzer Exp $
+
+IUSE="kde eutils"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Graphical CVS Client"
+SRC_URI="http://ppprs1.phy.tu-dresden.de/~trogisch/${PN}/download/LinCVS/${P}/${P}-0-generic-src.tgz"
+HOMEPAGE="http://www.lincvs.org"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+LICENSE="GPL-2"
+
+DEPEND="kde? ( >=kde-base/kdelibs-2 )
+ >=x11-libs/qt-3.0.5
+ >=cvs-1.9"
+
+RDEPEND="${DEPEND}
+ dev-util/cvs"
+
+src_compile() {
+ # Patch wrapper script
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ qmake -o Makefile lincvs.pro
+ sed -e "s/^\tstrip/#\tstrip/" -i Makefile
+ emake || die "make failed"
+ emake install || die "make install failed"
+}
+
+src_install () {
+ mkdir -p ${D}/usr/share
+ cp -pR ${S}/LinCVS ${D}/usr/share
+ dobin ${S}/LinCVS/lincvs
+}