summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-23 13:31:56 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-23 13:31:56 +0000
commit43098e31a50cc9866df943f92c007fe9ad305a51 (patch)
treed9ab45324169749d4effa8e14fd9f9a49b37972d /dev-util/memprof
parentrepoman'd (diff)
downloadhistorical-43098e31a50cc9866df943f92c007fe9ad305a51.tar.gz
historical-43098e31a50cc9866df943f92c007fe9ad305a51.tar.bz2
historical-43098e31a50cc9866df943f92c007fe9ad305a51.zip
repoman'd
Diffstat (limited to 'dev-util/memprof')
-rw-r--r--dev-util/memprof/memprof-0.4.1-r1.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/dev-util/memprof/memprof-0.4.1-r1.ebuild b/dev-util/memprof/memprof-0.4.1-r1.ebuild
index 23c8cf4bdcfe..48b63fa149c9 100644
--- a/dev-util/memprof/memprof-0.4.1-r1.ebuild
+++ b/dev-util/memprof/memprof-0.4.1-r1.ebuild
@@ -1,37 +1,36 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/memprof/memprof-0.4.1-r1.ebuild,v 1.2 2002/07/11 06:30:25 drobbins Exp $
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/memprof/memprof-0.4.1-r1.ebuild,v 1.3 2002/07/23 13:28:37 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="MemProf - Profiling and leak detection"
SRC_URI="http://people.redhat.com/otaylor/memprof/${P}.tar.gz"
HOMEPAGE="http://people.redhat.com/otaylor/memprof/"
-RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
sys-devel/binutils
>=gnome-base/libglade-0.17-r1"
-DEPEND="${RDEPEND}
+RDEPEND="${DEPEND}
nls? ( sys-devel/gettext )"
src_compile() {
local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --disable-more-warnings \
- $myconf || die
+ use nls || myconf="--disable-nls"
+
+ econf \
+ --disable-more-warnings \
+ ${myconf} || die
emake || die
}
src_install () {
make DESTDIR=${D} install || die
-
dodoc AUTHORS COPYING ChangeLog README NEWS TODO
}