summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-08-22 10:14:18 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-08-22 10:14:18 +0000
commit0ad5431eb1a1e69a6857aeaf0c09059660ced5e1 (patch)
treebb530e41936bb88abe60b355afa1e8bed0980de2 /dev-util/motor/motor-3.4.0-r1.ebuild
parentcleanup and fix pysqlite deps for slotted pysqlite-2 (#82511) (diff)
downloadhistorical-0ad5431eb1a1e69a6857aeaf0c09059660ced5e1.tar.gz
historical-0ad5431eb1a1e69a6857aeaf0c09059660ced5e1.tar.bz2
historical-0ad5431eb1a1e69a6857aeaf0c09059660ced5e1.zip
added patch for security purposes to 3.3.0 and 3.4.0 (#135020)(#113683). updated the gcc34 patch for 3.3.0.
Package-Manager: portage-2.1-r2
Diffstat (limited to 'dev-util/motor/motor-3.4.0-r1.ebuild')
-rw-r--r--dev-util/motor/motor-3.4.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/motor/motor-3.4.0-r1.ebuild b/dev-util/motor/motor-3.4.0-r1.ebuild
new file mode 100644
index 000000000000..db89e434c8df
--- /dev/null
+++ b/dev-util/motor/motor-3.4.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/motor/motor-3.4.0-r1.ebuild,v 1.1 2006/08/22 10:14:18 liquidx Exp $
+
+inherit eutils
+
+DESCRIPTION="text mode based programming environment for Linux"
+HOMEPAGE="http://thekonst.net/en/motor"
+SRC_URI="http://thekonst.net/download/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="nls"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/motor-3.2.2-security.patch"
+}
+
+src_compile() {
+ econf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS COPYING README TODO FAQ ChangeLog
+ docinto tutorial
+ dohtml -r tutorial/*
+}