summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-08-20 19:08:28 +0000
committerMichael Januszewski <spock@gentoo.org>2008-08-20 19:08:28 +0000
commit001e3e0ef9d2205ba43f618070317c067380c435 (patch)
tree96721112473ab5d654cc23b743c19c96fc47a51b /dev-util/oprofile/oprofile-0.9.4.ebuild
parentamd64/x86 stable, bug #235195 (diff)
downloadhistorical-001e3e0ef9d2205ba43f618070317c067380c435.tar.gz
historical-001e3e0ef9d2205ba43f618070317c067380c435.tar.bz2
historical-001e3e0ef9d2205ba43f618070317c067380c435.zip
Add a check for CONFIG_OPROFILE in the kernel's .config (bug #235285).
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26 x86_64
Diffstat (limited to 'dev-util/oprofile/oprofile-0.9.4.ebuild')
-rw-r--r--dev-util/oprofile/oprofile-0.9.4.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-util/oprofile/oprofile-0.9.4.ebuild b/dev-util/oprofile/oprofile-0.9.4.ebuild
index 543779566a8e..1daff42b79c7 100644
--- a/dev-util/oprofile/oprofile-0.9.4.ebuild
+++ b/dev-util/oprofile/oprofile-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.4.ebuild,v 1.2 2008/07/27 21:40:26 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.4.ebuild,v 1.3 2008/08/20 19:08:28 spock Exp $
EAPI=1
@@ -20,6 +20,14 @@ DEPEND=">=dev-libs/popt-1.7-r1
>=sys-libs/glibc-2.3.2-r1
qt3? ( x11-libs/qt:3 )"
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_chkconfig_present OPROFILE; then
+ elog "In order for oprofile to work, you need to configure your kernel"
+ elog "with CONFIG_OPROFILE set to 'm' or 'y'."
+ fi
+}
+
src_compile() {
local myconf=""