summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-07-14 16:36:50 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-07-14 16:36:50 +0000
commitda3e77faa56ec8d86e52ec8dc76ea4e6eb5d75e2 (patch)
treeaa74c49b3320b62bbac57ed87a10f738f41c5532 /dev-util/source-highlight
parentStable on hppa. (diff)
downloadhistorical-da3e77faa56ec8d86e52ec8dc76ea4e6eb5d75e2.tar.gz
historical-da3e77faa56ec8d86e52ec8dc76ea4e6eb5d75e2.tar.bz2
historical-da3e77faa56ec8d86e52ec8dc76ea4e6eb5d75e2.zip
Add check to see if boost is built with USE=threadsonly, otherwise in those cases it will try to use the (non-existent) non-threaded version.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-util/source-highlight')
-rw-r--r--dev-util/source-highlight/ChangeLog7
-rw-r--r--dev-util/source-highlight/Manifest10
-rw-r--r--dev-util/source-highlight/source-highlight-2.0.ebuild14
3 files changed, 23 insertions, 8 deletions
diff --git a/dev-util/source-highlight/ChangeLog b/dev-util/source-highlight/ChangeLog
index de20f5af709d..fc8b74072efc 100644
--- a/dev-util/source-highlight/ChangeLog
+++ b/dev-util/source-highlight/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/source-highlight
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/ChangeLog,v 1.14 2005/05/24 16:03:08 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/ChangeLog,v 1.15 2005/07/14 16:36:50 ka0ttic Exp $
+
+ 14 Jul 2005; Aaron Walker <ka0ttic@gentoo.org>
+ source-highlight-2.0.ebuild:
+ Add check to see if boost is built with USE=threadsonly, otherwise in those
+ cases it will try to use the (non-existent) non-threaded version.
*source-highlight-2.0 (24 May 2005)
diff --git a/dev-util/source-highlight/Manifest b/dev-util/source-highlight/Manifest
index 203c3717fa7c..d6ffa3d2fb3d 100644
--- a/dev-util/source-highlight/Manifest
+++ b/dev-util/source-highlight/Manifest
@@ -1,9 +1,9 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 b2a6a9a674f474e5c3ecafdecb5c3df4 source-highlight-2.0.ebuild 970
+MD5 ab4ebe965fc29cc52f85b89eebc035be source-highlight-2.0.ebuild 1168
MD5 a14c15abad083ecd2d10a02282b53e71 source-highlight-1.11-r2.ebuild 1015
-MD5 ee0844121b5ed814e29ea6c90961ce40 ChangeLog 2769
+MD5 fcdd33789f005ae15805fa3a9294323c ChangeLog 2996
MD5 f8d10f350e91f30316ea4e1bd1e76470 metadata.xml 254
MD5 ec136e3bf2efb4bdb6934e287a23cd6a files/digest-source-highlight-1.11-r2 73
MD5 8010d26caf8fbdd5b9c6ab34da1e492b files/source-highlight.bash-completion 1383
@@ -11,7 +11,7 @@ MD5 8983d7886a00affa478eb51c53f99f97 files/digest-source-highlight-2.0 72
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCk1BWEZCkKN40op4RAr0cAKC/Spvt3UxlcuAeam13Wn7++CYv2QCgqgYN
-tDhVO654LUtJ19Qvu+DeD9I=
-=bGs1
+iD8DBQFC1pS4EZCkKN40op4RAmVTAKCa7ZU0KsO0sT57wzWbZGZ/j5kwLQCfYtma
+tIR8FGQ7ZKAoH69/FDn23Ok=
+=rhEr
-----END PGP SIGNATURE-----
diff --git a/dev-util/source-highlight/source-highlight-2.0.ebuild b/dev-util/source-highlight/source-highlight-2.0.ebuild
index a15868d6c89a..9c348c807338 100644
--- a/dev-util/source-highlight/source-highlight-2.0.ebuild
+++ b/dev-util/source-highlight/source-highlight-2.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/source-highlight-2.0.ebuild,v 1.1 2005/05/24 16:03:08 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/source-highlight-2.0.ebuild,v 1.2 2005/07/14 16:36:50 ka0ttic Exp $
-inherit bash-completion versionator
+inherit bash-completion versionator eutils
MY_P="${PN}-$(replace_version_separator 2 -)"
S="${WORKDIR}/${MY_P}"
@@ -18,6 +18,16 @@ IUSE="doc"
DEPEND="virtual/libc
dev-libs/boost"
+src_compile() {
+ local myconf
+
+ built_with_use boost threadsonly && \
+ myconf="--with-boost-regex=boost_regex-gcc-mt"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
src_install () {
make DESTDIR="${D}" install || die "make install failed"
rm -fr ${D}/usr/share/doc