summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-06-16 08:34:46 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-06-16 08:34:46 +0000
commitbd7328e08f1927ca95ad655f57e903e37eea7ad5 (patch)
tree84578c9f62b31a4d67da6404a584510599f19e4c /dev-util/subversion/files
parentMerge in new device IDs from Debian ruleset, and fix udev symlinking (bug (diff)
downloadhistorical-bd7328e08f1927ca95ad655f57e903e37eea7ad5.tar.gz
historical-bd7328e08f1927ca95ad655f57e903e37eea7ad5.tar.bz2
historical-bd7328e08f1927ca95ad655f57e903e37eea7ad5.zip
fix #226577 again, fix #221931
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-util/subversion/files')
-rw-r--r--dev-util/subversion/files/1.5.0/http-library.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/subversion/files/1.5.0/http-library.patch b/dev-util/subversion/files/1.5.0/http-library.patch
new file mode 100644
index 000000000000..6d67465a076f
--- /dev/null
+++ b/dev-util/subversion/files/1.5.0/http-library.patch
@@ -0,0 +1,37 @@
+Index: subversion-1.5.0-rc9/configure.ac
+===================================================================
+--- subversion-1.5.0-rc9.orig/configure.ac
++++ subversion-1.5.0-rc9/configure.ac
+@@ -84,9 +84,19 @@ AC_ARG_ENABLE(neon-version-check,
+ [])
+ SVN_LIB_NEON($NEON_ALLOWED_LIST, $NEON_RECOMMENDED_VER, $NEON_URL)
+
++if test "$svn_lib_neon" = "yes"; then
++ AC_DEFINE([SVN_HAVE_NEON], 1,
++ [Defined if support for Neon is enabled])
++fi
++
+ dnl Search for serf as an alternative to neon
+ SVN_LIB_SERF
+
++if test "$svn_lib_serf" = "yes"; then
++ AC_DEFINE([SVN_HAVE_SERF], 1,
++ [Defined if support for Serf is enabled])
++fi
++
+ dnl Set up a number of directories ---------------------
+
+ dnl Create SVN_BINDIR for proper substitution
+Index: subversion-1.5.0-rc9/subversion/libsvn_ra/ra_loader.c
+===================================================================
+--- subversion-1.5.0-rc9.orig/subversion/libsvn_ra/ra_loader.c
++++ subversion-1.5.0-rc9/subversion/libsvn_ra/ra_loader.c
+@@ -59,7 +59,7 @@
+ ### any code which uses the pre-1.2 API svn_ra_get_ra_library
+ ### instead of svn_ra_open. */
+
+-#if defined(SVN_LIBSVN_CLIENT_LINKS_RA_NEON) && defined (SVN_LIBSVN_CLIENT_LINKS_RA_SERF)
++#if defined(SVN_HAVE_NEON) && defined(SVN_HAVE_SERF)
+ #define MUST_CHOOSE_DAV
+ #endif
+