summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-07-16 19:06:51 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-07-16 19:06:51 +0000
commit08643d2cc45b65e7ae2acd5a6b04bfe206507003 (patch)
treec87169b59f3dab555e62b9376954aade0a47be32 /dev-util
parentNew upstream version, and configurable repos location (diff)
downloadhistorical-08643d2cc45b65e7ae2acd5a6b04bfe206507003.tar.gz
historical-08643d2cc45b65e7ae2acd5a6b04bfe206507003.tar.bz2
historical-08643d2cc45b65e7ae2acd5a6b04bfe206507003.zip
New upstream version, and configurable repos location
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/subversion/Manifest6
-rw-r--r--dev-util/subversion/files/digest-subversion-0.25.02
-rw-r--r--dev-util/subversion/subversion-0.24.2-r1.ebuild24
-rw-r--r--dev-util/subversion/subversion-0.25.0.ebuild255
4 files changed, 274 insertions, 13 deletions
diff --git a/dev-util/subversion/Manifest b/dev-util/subversion/Manifest
index 48792af42f2c..3d878fddd9a6 100644
--- a/dev-util/subversion/Manifest
+++ b/dev-util/subversion/Manifest
@@ -2,12 +2,12 @@ MD5 d88c10d1a71e1912fb8f47491e3ae05b subversion-0.21.0-r1.ebuild 5784
MD5 c866c27917d94a227b66b5ce88274772 subversion-0.24.1.ebuild 7588
MD5 61e052a1c91f8ba072d291fb658cae9e subversion-0.22.2.ebuild 6852
MD5 63760c0eb65311b709cafd768855f5ea subversion-0.23.0.ebuild 6889
-MD5 bf030513ee7d93a10c8e84222805a04b subversion-0.24.2-r1.ebuild 7801
-MD5 2b68b8e7bdaecdb1667197906b11dc60 ChangeLog 4284
+MD5 d22cfd9948bf734132ceb12c0a65ddcd subversion-0.24.2-r1.ebuild 7801
+MD5 7c5d10ef03cb31eed2a7e5a0b0b68929 ChangeLog 4400
MD5 766fd60eb6ace2ac6e79b38001cb0881 subversion-0.24.2.ebuild 7665
MD5 94a82b90df7338731c1f8d4a654edb8a metadata.xml 151
MD5 a343df53435bdcfc3a4c85f3e9912102 subversion-0.10_pre1.ebuild 8054
-MD5 402429c55602a3720c04d33a3370c039 subversion-0.25.0.ebuild 7813
+MD5 ae6017b40fedc270b449d0728f9b4660 subversion-0.25.0.ebuild 7852
MD5 7a45c9dae1829ed6fa2b22ead64c4eab subversion-0.21.0.ebuild 6494
MD5 8208be10eefcdc258afb4ca8d410a06c files/digest-subversion-0.10_pre1 446
MD5 d3250565b5dca16ba84df4bb5075992b files/digest-subversion-0.21.0 132
diff --git a/dev-util/subversion/files/digest-subversion-0.25.0 b/dev-util/subversion/files/digest-subversion-0.25.0
new file mode 100644
index 000000000000..63dba431ecb9
--- /dev/null
+++ b/dev-util/subversion/files/digest-subversion-0.25.0
@@ -0,0 +1,2 @@
+MD5 12262c64fcd64b772e7cffad8e4d0ebc db-4.0.14.tar.gz 2701799
+MD5 a018220d5c790161bc712ccb7d0f1b38 subversion-0.25.tar.gz 5821703
diff --git a/dev-util/subversion/subversion-0.24.2-r1.ebuild b/dev-util/subversion/subversion-0.24.2-r1.ebuild
index 6e9ea5567d6f..b078150900a4 100644
--- a/dev-util/subversion/subversion-0.24.2-r1.ebuild
+++ b/dev-util/subversion/subversion-0.24.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-0.24.2-r1.ebuild,v 1.1 2003/07/15 09:47:23 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-0.24.2-r1.ebuild,v 1.2 2003/07/16 19:06:41 pauldv Exp $
inherit libtool
@@ -15,6 +15,10 @@ LICENSE="Apache-1.1"
KEYWORDS="~x86 ~ppc"
IUSE="ssl apache2 berkdb python"
+if [ "${SVN_REPOS_LOC}x" = "x" ]; then
+ SVN_REPOS_LOC="/home/svn"
+fi
+
#
#
# Note that to disable the server part of subversion you need to specify
@@ -192,10 +196,10 @@ src_install () {
</IfModule>
<Location /svn/repos>
DAV svn
- SVNPath /home/svn/repos
+ SVNPath ${SVN_REPOS_LOC}/repos
AuthType Basic
AuthName "Subversion repository"
- AuthUserFile /home/svn/conf/svnusers
+ AuthUserFile ${SVN_REPOS_LOC}/conf/svnusers
Require valid-user
</Location>
</IfDefine>
@@ -219,7 +223,7 @@ pkg_postinst() {
if use apache2; then
einfo "To allow web access a htpasswd file needs to be created using the"
einfo "following command:"
- einfo " htpasswd2 -m -c /home/svn/conf/svnusers USERNAME"
+ einfo " htpasswd2 -m -c ${SVN_REPOS_LOC}/conf/svnusers USERNAME"
fi
else
einfo "Your subversion is client only as the server is only build when"
@@ -232,18 +236,18 @@ pkg_config() {
die "You seem to only have build the subversion client"
fi
einfo ">>> Initializing the database ..."
- if [ -f /home/svn/repos ] ; then
+ if [ -f ${SVN_REPOS_LOC}/repos ] ; then
echo "A subversion repository already exists and I will not overwrite it."
- echo "Delete /home/svn/repos first if you're sure you want to have a clean version."
+ echo "Delete ${SVN_REPOS_LOC}/repos first if you're sure you want to have a clean version."
else
- mkdir -p /home/svn
+ mkdir -p ${SVN_REPOS_LOC}
einfo ">>> Populating repository directory ..."
# create initial repository
- /usr/bin/svnadmin create /home/svn/repos
+ /usr/bin/svnadmin create ${SVN_REPOS_LOC}/repos
einfo ">>> Setting repository permissions ..."
- chown -Rf apache.apache /home/svn/repos
- chmod -Rf 755 /home/svn/repos
+ chown -Rf apache.apache ${SVN_REPOS_LOC}/repos
+ chmod -Rf 755 ${SVN_REPOS_LOC}/repos
fi
}
diff --git a/dev-util/subversion/subversion-0.25.0.ebuild b/dev-util/subversion/subversion-0.25.0.ebuild
new file mode 100644
index 000000000000..b99268745653
--- /dev/null
+++ b/dev-util/subversion/subversion-0.25.0.ebuild
@@ -0,0 +1,255 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-0.25.0.ebuild,v 1.1 2003/07/16 19:06:41 pauldv Exp $
+
+inherit libtool
+
+DB_VERSION="4.0.14"
+DESCRIPTION="A compelling replacement for CVS"
+SRC_URI="berkdb? ( http://www.sleepycat.com/update/snapshot/db-${DB_VERSION}.tar.gz )
+ http://subversion.tigris.org/files/documents/15/5110/${PN}-${PV//.0/}.tar.gz"
+HOMEPAGE="http://subversion.tigris.org/"
+
+SLOT="0"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86 ~ppc"
+IUSE="ssl apache2 berkdb python"
+
+S=${WORKDIR}/${PN}-${PV//.0}
+
+if [ "${SVN_REPOS_LOC}x" = "x" ]; then
+ SVN_REPOS_LOC="/home/svn"
+fi
+
+#
+#
+# Note that to disable the server part of subversion you need to specify
+# USE="-berkdb" emerge subversion.
+#
+#
+
+S_DB="${WORKDIR}/db-${DB_VERSION}/build_unix"
+
+DEPEND="python? ( >=dev-lang/python-2.0 )
+ >=sys-apps/diffutils-2.7.7
+ >=sys-devel/libtool-1.4.1-r1
+ >=sys-devel/bison-1.28-r3
+ apache2? ( >=net-www/apache-2.0.45 )
+ !apache2? ( !>=apache-2* )
+ !dev-libs/apr
+ ~sys-devel/m4-1.4
+ python? ( >=dev-lang/swig-1.3.16 )
+ >=net-misc/neon-0.23.8"
+
+RDEPEND="python? ( >=dev-lang/python-2.0 )
+ >=sys-apps/diffutils-2.7.7
+ ~sys-devel/m4-1.4"
+
+pkg_setup() {
+ if use apache2; then
+ einfo "The apache2 subversion module will be built, and libapr from the"
+ einfo "apache package will be used instead of the included"
+ else
+ einfo "Please note that subversion and apache2 cannot be installed"
+ einfo "simultaneously without specifying the apache2 use flag. This is"
+ einfo "because subversion installs its own libapr and libapr-util in that"
+ einfo "case."
+ fi
+}
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${PN}-${PV//.0/}.tar.gz
+ use berkdb && ( has_version =db-4* || (
+ unpack db-${DB_VERSION}.tar.gz
+ ) )
+ cd ${S}
+ elibtoolize ${S}
+}
+
+src_compile() {
+ local myconf
+ use berkdb && ( has_version =db-4* || (
+ cd ${S_DB}
+ ../dist/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-compat185 \
+ --disable-cxx \
+ --disable-tcl \
+ --disable-java \
+ --disable-shared \
+ --with-uniquename
+ emake || make || die "db make failed"
+ [ -e ${WORKDIR}/dbinst ] && rm -rf ${WORKDIR}/dbinst
+ mkdir -p ${WORKDIR}/dbinst/lib
+ make prefix=${WORKDIR}/dbinst install ||die
+ mkdir ${WORKDIR}/dbinst/include/db4
+ cp ${WORKDIR}/dbinst/include/*.h ${WORKDIR}/dbinst/include/db4
+ mv ${WORKDIR}/dbinst/lib/libdb.a ${WORKDIR}/dbinst/lib/libdb4.a
+ cat <<EOF >${WORKDIR}/dbinst/lib/libdb4.so
+GROUP( ${WORKDIR}/dbinst/lib/libdb4.a /usr/lib/libdb.so)
+EOF
+ ) ) #no db4
+
+ cd ${S}
+ use ssl && myconf="${myconf} --with-ssl"
+ use ssl || myconf="${myconf} --without-ssl"
+
+ use apache2 && myconf="${myconf} --with-apxs=/usr/sbin/apxs2 \
+ --with-apr=/usr --with-apr-util=/usr"
+ use apache2 || myconf="${myconf} --without-apxs"
+
+ if use berkdb; then
+ has_version =db-4* && myconf="${myconf} --with-berkeley-db"
+ has_version =db-4* || myconf="${myconf} --with-berkeley-db=${WORKDIR}/dbinst"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ use python && myconf="${myconf} --with-python=/usr/bin/python --with-swig"
+ use python || myconf="${myconf} --without-python --without-swig"
+
+ echo "myconf=${myconf}"
+ econf ${myconf} \
+ --with-neon=/usr \
+ --disable-experimental-libtool \
+ --disable-mod-activation ||die "configuration failed"
+
+
+ # build subversion, but do it in a way that is safe for paralel builds
+ # Also apparently the included apr does have a libtool that doesn't like
+ # -L flags. So not specifying it at all when not building apache modules
+ # and only specify it for internal parts otherwise
+ if use apache2; then
+ ( emake external-all && emake LT_LDFLAGS="-L${D}/usr/lib" local-all ) || die "make of subversion failed"
+ else
+ ( emake external-all && emake local-all ) || die "make of subversion failed"
+ fi
+
+ #building fails without the apache apr-util as includes are wrong.
+ #Also the python bindings do not work without db installed
+ if use python; then
+ if use berkdb; then
+ if use apache2; then
+ emake swig-py || die "subversion python bindings failed"
+ else
+ emake SVN_APR_INCLUDES="-I${S}/apr/include -I${S}/apr-util/include" swig-py || die "subversion python bindings failed"
+ fi
+ fi
+ fi
+}
+
+
+src_install () {
+ mkdir -p ${D}/etc/apache2/conf
+ mkdir -p ${D}/etc/share
+
+ use berkdb && ( has_version =db-4* || (
+ mkdir -p ${D}/usr/share/subversion/bin
+ cp ${WORKDIR}/dbinst/bin/* ${D}/usr/share/subversion/bin/
+ ) )
+
+ make DESTDIR=${D} install || die "Installation of subversion failed"
+ if [ -e ${D}/usr/lib/apache2 ]; then
+ mv ${D}/usr/lib/apache2 ${D}/usr/lib/apache2-extramodules
+ fi
+
+ if use python; then
+ if use berkdb; then
+ make install-swig-py DESTDIR=${D} DISTUTIL_PARAM=--prefix=${D} || die "Installation of subversion python bindings failed"
+ # install cvs2svn
+ dobin tools/cvs2svn/cvs2svn.py
+ mv ${D}/usr/bin/cvs2svn.py ${D}/usr/bin/cvs2svn
+ doman tools/cvs2svn/cvs2svn.1
+
+ # move python bindings
+ mkdir -p ${D}/usr/lib/python2.2/site-packages
+ cp -r tools/cvs2svn/rcsparse ${D}/usr/lib/python2.2/site-packages
+ mv ${D}/usr/lib/svn-python/svn ${D}/usr/lib/python2.2/site-packages
+ mv ${D}/usr/lib/svn-python/libsvn ${D}/usr/lib/python2.2/site-packages
+ rmdir ${D}/usr/lib/svn-python
+ fi
+ fi
+
+ dodoc BUGS COMMITTERS COPYING HACKING IDEAS INSTALL PORTING README
+ dodoc CHANGES
+ dodoc tools/xslt/svnindex.css tools/xslt/svnindex.xsl
+
+ # install documentation
+ docinto notes
+ for f in notes/*
+ do
+ [ -f ${f} ] && dodoc ${f}
+ done
+ cd ${S}
+ echo "installing html book"
+ dohtml -r doc/book/book/book.html doc/book/book/styles.css doc/book/book/images
+ if use apache2; then
+ mkdir -p ${D}/etc/apache2/conf/modules.d
+ cat <<EOF >${D}/etc/apache2/conf/modules.d/47_mod_dav_svn.conf
+<IfDefine SVN>
+ <IfModule !mod_dav_svn.c>
+ LoadModule dav_svn_module extramodules/mod_dav_svn.so
+ </IfModule>
+ <Location /svn/repos>
+ DAV svn
+ SVNPath ${SVN_REPOS_LOC}/repos
+ AuthType Basic
+ AuthName "Subversion repository"
+ AuthUserFile ${SVN_REPOS_LOC}/conf/svnusers
+ Require valid-user
+ </Location>
+</IfDefine>
+EOF
+ fi
+}
+
+pkg_postinst() {
+ if use berkdb; then
+ if use apache2; then
+ einfo "Subversion has multiple server types. To enable the http based version"
+ einfo "you must edit /etc/conf.d/apache2 to include both \"-D DAV\" and \"-D SVN\""
+ einfo ""
+ fi
+ einfo "A repository needs to be created using the ebuild ${PN} config command"
+ if has_version =sys-libs/db-4*; then
+ einfo "If you upgraded from an older version of berkely db and experience"
+ einfo "problems with your repository then run the following command:"
+ einfo " su apache -c \"db4_recover -h /path/to/repos\""
+ fi
+ if use apache2; then
+ einfo "To allow web access a htpasswd file needs to be created using the"
+ einfo "following command:"
+ einfo " htpasswd2 -m -c ${SVN_REPOS_LOC}/conf/svnusers USERNAME"
+ fi
+ else
+ einfo "Your subversion is client only as the server is only build when"
+ einfo "the berkdb flag is set"
+ fi
+}
+
+pkg_config() {
+ if [ ! -x /usr/bin/svnadmin ]; then
+ die "You seem to only have build the subversion client"
+ fi
+ einfo ">>> Initializing the database ..."
+ if [ -f ${SVN_REPOS_LOC}/repos ] ; then
+ echo "A subversion repository already exists and I will not overwrite it."
+ echo "Delete ${SVN_REPOS_LOC}/repos first if you're sure you want to have a clean version."
+ else
+ mkdir -p ${SVN_REPOS_LOC}
+ einfo ">>> Populating repository directory ..."
+ # create initial repository
+ /usr/bin/svnadmin create ${SVN_REPOS_LOC}/repos
+
+ einfo ">>> Setting repository permissions ..."
+ chown -Rf apache.apache ${SVN_REPOS_LOC}/repos
+ chmod -Rf 755 ${SVN_REPOS_LOC}/repos
+ fi
+}
+