summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Belt <gaarde@gentoo.org>2002-08-28 02:57:34 +0000
committerPaul Belt <gaarde@gentoo.org>2002-08-28 02:57:34 +0000
commit7d1bff331612467a8373944e098b5e61b1c4197c (patch)
treece2fdc5edc9b87dcbf13b4a65eccc557279bd043 /dev-util
parentversion bump and SRC_URI change (diff)
downloadhistorical-7d1bff331612467a8373944e098b5e61b1c4197c.tar.gz
historical-7d1bff331612467a8373944e098b5e61b1c4197c.tar.bz2
historical-7d1bff331612467a8373944e098b5e61b1c4197c.zip
rats security auditing utility for C, C++, Perl, and Python code
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rats/files/digest-rats-1.51
-rw-r--r--dev-util/rats/rats-1.5.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/rats/files/digest-rats-1.5 b/dev-util/rats/files/digest-rats-1.5
new file mode 100644
index 000000000000..9c0a69b526df
--- /dev/null
+++ b/dev-util/rats/files/digest-rats-1.5
@@ -0,0 +1 @@
+MD5 628e4c6000ab635b1894945c09cc1d2c rats-1.5.tar.gz 301972
diff --git a/dev-util/rats/rats-1.5.ebuild b/dev-util/rats/rats-1.5.ebuild
new file mode 100644
index 000000000000..8dd84232d797
--- /dev/null
+++ b/dev-util/rats/rats-1.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rats/rats-1.5.ebuild,v 1.1 2002/08/28 02:57:34 gaarde Exp $
+
+# Author: Paul Belt <gaarde@gentoo.org>
+
+DESCRIPTION="RATS, the Rough Auditing Tool for Security, is a security auditing utility for C, C++, Perl, and Python code. RATS scans source code, finding potentially dangerous function calls. It provides a reasonable starting point for performing manual security audits."
+HOMEPAGE="http://www.securesoftware.com/rats.php"
+SRC_URI="http://www.securesoftware.com/rats/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf --mandir=${D}/usr/share/man/man1 || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+}