summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-11-11 16:15:33 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-11-11 16:15:33 +0000
commit7d570263db3f6fbb5aa59fe236ad255af1ae8e67 (patch)
tree01a43ceefe003f95490ab16853c0ec279ff45f4a /dev-util
parentAdded catalyst 2.0 mask for pre-release versions. (diff)
downloadhistorical-7d570263db3f6fbb5aa59fe236ad255af1ae8e67.tar.gz
historical-7d570263db3f6fbb5aa59fe236ad255af1ae8e67.tar.bz2
historical-7d570263db3f6fbb5aa59fe236ad255af1ae8e67.zip
Added catalyst 2.0_pre20051111. This is the first catalyst 2.0 pre-release version available to the public, so please test it thoroughly.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/ChangeLog10
-rw-r--r--dev-util/catalyst/Manifest7
-rw-r--r--dev-util/catalyst/catalyst-2.0_pre20051111.ebuild94
-rw-r--r--dev-util/catalyst/files/catalyst-2.0_pre20051111-slot.patch30
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0_pre200511111
5 files changed, 139 insertions, 3 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index d20abf6b5de3..b2c345eca647 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/catalyst
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.90 2005/07/29 22:21:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.91 2005/11/11 16:15:32 wolf31o2 Exp $
+
+*catalyst-2.0_pre20051111 (11 Nov 2005)
+
+ 11 Nov 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/catalyst-2.0_pre20051111-slot.patch,
+ +catalyst-2.0_pre20051111.ebuild:
+ Added catalyst 2.0_pre20051111. This is the first catalyst 2.0 pre-release
+ version available to the public, so please test it thoroughly.
*catalyst-1.1.10.10 (29 Jul 2005)
diff --git a/dev-util/catalyst/Manifest b/dev-util/catalyst/Manifest
index 31b77206a9ec..1f60b6016fea 100644
--- a/dev-util/catalyst/Manifest
+++ b/dev-util/catalyst/Manifest
@@ -1,4 +1,7 @@
-MD5 4fb2d360302d96e69b823fb4a697beae ChangeLog 15380
+MD5 a9a44c12d8fd6dfd9bc3507e4a8f2967 ChangeLog 15700
MD5 f514d037aa3187a2e5a96fe6c4ae626b catalyst-1.1.10.10.ebuild 2250
-MD5 8c971ca7e043237b69754a9d88238bd4 metadata.xml 223
+MD5 eba15dd7093e97f7352f2ea7c5e40b53 catalyst-2.0_pre20051111.ebuild 2927
+MD5 cebad81378438c98cb620656705e3e67 files/catalyst-2.0_pre20051111-slot.patch 1282
MD5 1579d7c79eaa1035a84a4247cd4a5fb6 files/digest-catalyst-1.1.10.10 71
+MD5 120714bab01a470a4f31f40a24e3a822 files/digest-catalyst-2.0_pre20051111 77
+MD5 8c971ca7e043237b69754a9d88238bd4 metadata.xml 223
diff --git a/dev-util/catalyst/catalyst-2.0_pre20051111.ebuild b/dev-util/catalyst/catalyst-2.0_pre20051111.ebuild
new file mode 100644
index 000000000000..39f525733430
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0_pre20051111.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_pre20051111.ebuild,v 1.1 2005/11/11 16:15:33 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux official release metatool"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
+IUSE="doc ccache cdr examples"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ amd64? (
+ sys-apps/linux32 )
+ ppc64? (
+ sys-devel/ppc32 )
+ ccache? (
+ dev-util/ccache )
+ cdr? (
+ virtual/cdrtools
+ app-misc/zisofs-tools
+ !mips? ( >=sys-fs/squashfs-tools-2.1 ) )
+ examples? (
+ dev-util/livecd-kconfigs
+ dev-util/livecd-specs )"
+
+pkg_setup() {
+ if use ccache
+ then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ if use examples || use doc
+ then
+ ewarn "The examples and documentation in this experimental ebuild have"
+ ewarn "not been fully updated. Please use the gentoo-catalyst mailing"
+ ewarn "list if you have any issues with this build."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-slot.patch
+}
+
+src_install() {
+ ewarn "This version of the ebuild is slotted to allow side-by-side"
+ ewarn "installation with catalyst 1.x for use on build servers. The final"
+ ewarn "version of this ebuild will not be slotted, as catalyst 2.0 is to"
+ ewarn "supercede catalyst 1.x in every way. It is currently slotted for"
+ ewarn "testing purposes only."
+ insinto /usr/lib/${PN}2/arch
+ doins arch/* || die "copying arch/*"
+ insinto /usr/lib/${PN}2/modules
+ doins modules/* || die "copying modules/*"
+ insinto /usr/lib/${PN}2/livecd/cdtar
+ doins livecd/cdtar/* || die "copying cdtar/*"
+ insinto /usr/lib/${PN}2/livecd/files
+ doins livecd/files/* || die "copying files/*"
+ for x in targets/*; do
+ exeinto /usr/lib/${PN}2/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ exeinto /usr/lib/${PN}2
+ newexe catalyst catalyst2 || die "copying catalyst"
+ dodir /usr/bin
+ dosym /usr/lib/${PN}2/catalyst2 /usr/bin/catalyst2
+ insinto /etc/catalyst2
+ newins files/catalyst.conf catalyst2.conf
+ if use doc; then
+ DOCDESTTREE="." dohtml -A spec,msg,example -r examples files
+ fi
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ newman files/catalyst.1 catalyst2.1
+ # This will go away in the future
+ dosed "s:/usr/lib/catalyst:/usr/lib/catalyst2:" /etc/catalyst2/catalyst2.conf
+ dosed "s:/var/tmp/catalyst:/var/tmp/catalyst2:" /etc/catalyst2/catalyst2.conf
+}
+
+pkg_postinst() {
+ echo
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/files/catalyst-2.0_pre20051111-slot.patch b/dev-util/catalyst/files/catalyst-2.0_pre20051111-slot.patch
new file mode 100644
index 000000000000..181eadfd481a
--- /dev/null
+++ b/dev-util/catalyst/files/catalyst-2.0_pre20051111-slot.patch
@@ -0,0 +1,30 @@
+diff -urN catalyst-2.0_pre20051111.orig/catalyst catalyst-2.0_pre20051111/catalyst
+--- catalyst-2.0_pre20051111.orig/catalyst 2005-10-17 16:07:14.000000000 -0400
++++ catalyst-2.0_pre20051111/catalyst 2005-10-17 16:06:23.000000000 -0400
+@@ -50,10 +50,10 @@
+ myconf={}
+ config_file=""
+
+- confdefaults={ "storedir":"/var/tmp/catalyst",\
+- "sharedir":"/usr/share/catalyst","distdir":"/usr/portage/distfiles",\
++ confdefaults={ "storedir":"/var/tmp/catalyst2",\
++ "sharedir":"/usr/share/catalyst2","distdir":"/usr/portage/distfiles",\
+ "portdir":"/usr/portage","options":"",\
+- "snapshot_cache":"/var/tmp/catalyst/snapshot_cache" }
++ "snapshot_cache":"/var/tmp/catalyst2/snapshot_cache" }
+
+ # first, try the one passed (presumably from the cmdline)
+ if myconfig:
+@@ -67,9 +67,9 @@
+ sys.exit(1)
+
+ # next, try the default location
+- elif os.path.exists("/etc/catalyst/catalyst.conf"):
+- print "Using default Catalyst configuration file, /etc/catalyst/catalyst.conf"
+- config_file="/etc/catalyst/catalyst.conf"
++ elif os.path.exists("/etc/catalyst2/catalyst2.conf"):
++ print "Using default Catalyst configuration file, /etc/catalyst2/catalyst2.conf"
++ config_file="/etc/catalyst2/catalyst2.conf"
+
+ # can't find a config file (we are screwed), so bail out
+ else:
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0_pre20051111 b/dev-util/catalyst/files/digest-catalyst-2.0_pre20051111
new file mode 100644
index 000000000000..1fb735d31734
--- /dev/null
+++ b/dev-util/catalyst/files/digest-catalyst-2.0_pre20051111
@@ -0,0 +1 @@
+MD5 70b4749587209b1e3ab385ee5fc98c84 catalyst-2.0_pre20051111.tar.bz2 698475