summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-01 05:19:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-01 05:19:54 +0000
commitc8beeb203e5dd5a06c9425befd9a40dac9d1e927 (patch)
tree02f1e9486deace2fd541e775ae1dbc357852691f /dev-util
parentstabilize (diff)
downloadhistorical-c8beeb203e5dd5a06c9425befd9a40dac9d1e927.tar.gz
historical-c8beeb203e5dd5a06c9425befd9a40dac9d1e927.tar.bz2
historical-c8beeb203e5dd5a06c9425befd9a40dac9d1e927.zip
clean up and make it better
Package-Manager: portage-2.0.51.20-r5
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git-pasky/Manifest4
-rw-r--r--dev-util/git-pasky/files/Makefile.patch6
-rw-r--r--dev-util/git-pasky/git-pasky-0.7.ebuild21
3 files changed, 16 insertions, 15 deletions
diff --git a/dev-util/git-pasky/Manifest b/dev-util/git-pasky/Manifest
index 681ede3d7e04..0cc32ce9c343 100644
--- a/dev-util/git-pasky/Manifest
+++ b/dev-util/git-pasky/Manifest
@@ -1,6 +1,6 @@
MD5 4efd1b43972e810d9f05df92c4859576 ChangeLog 512
-MD5 3b8aea16257c238d95935aa57883d10c git-pasky-0.7.ebuild 1064
+MD5 de465cf0968623a4b543db436f62217e git-pasky-0.7.ebuild 1038
MD5 78c1b34edd1399c24d7d9e59212bc17a metadata.xml 221
-MD5 1a35829a7608cc88ae10ede9b2cc2630 files/Makefile.patch 674
+MD5 7db530d4022de396668274eae68f560b files/Makefile.patch 588
MD5 6bf7a8b9b7d8cc7c3473bd48fa9ba5b1 files/commit-id.patch 216
MD5 2e1e19fd9287dfccfea81c7d66d42d69 files/digest-git-pasky-0.7 66
diff --git a/dev-util/git-pasky/files/Makefile.patch b/dev-util/git-pasky/files/Makefile.patch
index 039778fb3f22..b4b32c7a740e 100644
--- a/dev-util/git-pasky/files/Makefile.patch
+++ b/dev-util/git-pasky/files/Makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2005-04-22 02:04:53.000000000 +0100
-+++ Makefile 2005-04-22 17:15:05.722557768 +0100
+--- Makefile
++++ Makefile
@@ -12,10 +12,8 @@
# BREAK YOUR LOCAL DIFFS! show-diff and anything using it will likely randomly
# break unless your underlying filesystem supports those sub-second times
@@ -8,7 +8,7 @@
-
# Should be changed to /usr/local
-prefix=$(HOME)
-+prefix=$(DESTDIR)/usr/
++prefix=/usr/
bindir=$(prefix)/bin
diff --git a/dev-util/git-pasky/git-pasky-0.7.ebuild b/dev-util/git-pasky/git-pasky-0.7.ebuild
index 8f8b23745f03..3564aceabbb7 100644
--- a/dev-util/git-pasky/git-pasky-0.7.ebuild
+++ b/dev-util/git-pasky/git-pasky-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git-pasky/git-pasky-0.7.ebuild,v 1.3 2005/04/29 13:49:48 r3pek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git-pasky/git-pasky-0.7.ebuild,v 1.4 2005/05/01 05:19:54 vapier Exp $
inherit eutils
@@ -14,21 +14,21 @@ KEYWORDS="~x86 ~amd64"
IUSE="mozsha1 ppcsha1"
DEPEND="dev-libs/openssl
- sys-libs/zlib
- !dev-util/git
- !dev-util/cogito"
+ sys-libs/zlib
+ !dev-util/git
+ !dev-util/cogito"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/Makefile.patch || die "epatch makefile failed"
- epatch ${FILESDIR}/commit-id.patch || die "epatch commit-id failed"
+ cd "${S}"
+ epatch "${FILESDIR}"/Makefile.patch
+ epatch "${FILESDIR}"/commit-id.patch
}
src_compile() {
- if use mozsha1; then
+ if use mozsha1 ; then
export MOZILLA_SHA1=yes
- elif use ppcsha1; then
+ elif use ppcsha1 ; then
export PPC_SHA1=yes
fi
@@ -36,7 +36,8 @@ src_compile() {
}
src_install() {
- einstall || die "einstall failed"
+ make install DESTDIR="${D}" || die "install failed"
+ dodoc README*
}
pkg_postinst() {