summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2008-06-03 14:19:33 +0000
committerTristan Heaven <tristan@gentoo.org>2008-06-03 14:19:33 +0000
commit5db1e904f5e16665abfa75335bde8933f2d7429b (patch)
tree66f37cc87a965a45e277e71ab4dd9a312878b887 /games-action/openastromenace/files
parentamd64 stable, bug 224305 (diff)
downloadhistorical-5db1e904f5e16665abfa75335bde8933f2d7429b.tar.gz
historical-5db1e904f5e16665abfa75335bde8933f2d7429b.tar.bz2
historical-5db1e904f5e16665abfa75335bde8933f2d7429b.zip
Fix build error with cmake-2.6
Package-Manager: portage-2.2_pre7-r1/cvs/Linux 2.6.25.4 Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz
Diffstat (limited to 'games-action/openastromenace/files')
-rw-r--r--games-action/openastromenace/files/openastromenace-1.2.0-cmake.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-action/openastromenace/files/openastromenace-1.2.0-cmake.patch b/games-action/openastromenace/files/openastromenace-1.2.0-cmake.patch
new file mode 100644
index 000000000000..17e194704d7e
--- /dev/null
+++ b/games-action/openastromenace/files/openastromenace-1.2.0-cmake.patch
@@ -0,0 +1,26 @@
+--- CMakeLists.txt 2008/02/15 09:55:15 33
++++ CMakeLists.txt 2008/05/19 08:11:36 36
+@@ -13,6 +13,8 @@
+ # ./AstroMenace
+ #
+
++CMAKE_MINIMUM_REQUIRED(VERSION 2.4)
++
+ # project name
+ PROJECT(AstroMenace)
+
+@@ -43,9 +45,12 @@
+ IF(DEFINED DATADIR)
+ ADD_DEFINITIONS(-DDATADIR=\\"${DATADIR}\\")
+ ENDIF(DEFINED DATADIR)
+- ADD_DEFINITIONS(`${SDL_CONFIG} --cflags` -Wall)
++ EXEC_PROGRAM(${SDL_CONFIG} ARGS "--cflags" OUTPUT_VARIABLE SDL_CFLAGS)
++ EXEC_PROGRAM(${SDL_CONFIG} ARGS "--libs" OUTPUT_VARIABLE SDL_LIBS)
++
++ ADD_DEFINITIONS(${SDL_CFLAGS})
+ ADD_EXECUTABLE(AstroMenace ${astromenace_SRCS})
+- TARGET_LINK_LIBRARIES(AstroMenace `${SDL_CONFIG} --libs` ${OPENGL_gl_LIBRARY} ${OPENAL_LIBRARY} ${JPEG_LIBRARY} ${GLU_LIBRARY} -lalut -lvorbis -lvorbisfile)
++ TARGET_LINK_LIBRARIES(AstroMenace ${SDL_LIBS} ${OPENGL_gl_LIBRARY} ${OPENAL_LIBRARY} ${JPEG_LIBRARY} ${GLU_LIBRARY} -lalut -lvorbis -lvorbisfile)
+ IF(CYGWIN)
+ TARGET_LINK_LIBRARIES(AstroMenace -lGL.dll -lGLU.dll -lglfw -lX11.dll)
+ # ADD_DEFINITIONS(-mno-cygwin)