summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-09-17 23:39:16 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-09-17 23:39:16 +0000
commit88d16f412f3dcec5ef90cbdef1c2669fa23182a1 (patch)
treef875fd767802f6584eae2fa61f9d16a2d2641a1f /games-action/xpilot-ng/xpilot-ng-4.6.6.ebuild
parentInitial import. Ebuild submitted to bug #62537 by Lars Diesselberg <larsdies... (diff)
downloadhistorical-88d16f412f3dcec5ef90cbdef1c2669fa23182a1.tar.gz
historical-88d16f412f3dcec5ef90cbdef1c2669fa23182a1.tar.bz2
historical-88d16f412f3dcec5ef90cbdef1c2669fa23182a1.zip
Initial import. Ebuild submitted to bug #62537 by Lars Diesselberg <larsdiesselberg@gmx.de>. Closing bug #62537.
Diffstat (limited to 'games-action/xpilot-ng/xpilot-ng-4.6.6.ebuild')
-rw-r--r--games-action/xpilot-ng/xpilot-ng-4.6.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-action/xpilot-ng/xpilot-ng-4.6.6.ebuild b/games-action/xpilot-ng/xpilot-ng-4.6.6.ebuild
new file mode 100644
index 000000000000..789b2cd2938e
--- /dev/null
+++ b/games-action/xpilot-ng/xpilot-ng-4.6.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot-ng/xpilot-ng-4.6.6.ebuild,v 1.1 2004/09/17 23:39:16 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="Improvement of the multiplayer space game XPilot"
+HOMEPAGE="http://xpilot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xpilot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="openal sdl"
+
+DEPEND="virtual/x11
+ >=dev-libs/expat-1.1
+ >=sys-libs/zlib-1.1.3
+ openal? ( media-libs/openal )
+ sdl? (
+ virtual/opengl
+ >=media-libs/libsdl-1.2.0
+ >=media-libs/sdl-image-1.0
+ >=media-libs/sdl-ttf-2.0 )"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable sdl sdl-client) \
+ $(use_enable openal sound) \
+ || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+ prepgamesdirs
+}
+