summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2009-06-17 23:32:42 +0000
committerTristan Heaven <tristan@gentoo.org>2009-06-17 23:32:42 +0000
commit51fcf9051b8cde59719a47e79e40f8ee432ecafc (patch)
tree9b8d77d1a8b563e78a22efccf2c59bb610b43879 /games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
parentadd fix from upstream for compatibility with latest cmake (diff)
downloadhistorical-51fcf9051b8cde59719a47e79e40f8ee432ecafc.tar.gz
historical-51fcf9051b8cde59719a47e79e40f8ee432ecafc.tar.bz2
historical-51fcf9051b8cde59719a47e79e40f8ee432ecafc.zip
Respect LDFLAGS; install menu entry
Package-Manager: portage-2.2_rc33/cvs/Linux i686
Diffstat (limited to 'games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild')
-rw-r--r--games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
index 96f4f58fe074..16a6389bd27b 100644
--- a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
+++ b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.13 2009/06/17 23:13:36 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.14 2009/06/17 23:32:42 nyhm Exp $
EAPI=2
inherit eutils toolchain-funcs games
@@ -46,8 +46,8 @@ src_compile() {
cd src
emake CXXFLAGS="$CXXFLAGS $(sdl-config --cflags)" $(echo *.cpp | sed 's/\.cpp/.o/g') \
|| die "emake failed"
- $(tc-getCXX) -o ${PN} *.o -lpthread -lSDL -lSDL_ttf -lSDL_mixer || \
- die "couldnt produce binary"
+ $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -o ${PN} *.o -lpthread -lSDL -lSDL_ttf -lSDL_mixer \
+ || die "cxx failed"
}
src_install() {
@@ -61,5 +61,7 @@ src_install() {
newins hscore.dat ${PN}-hscore.dat || die "newins failed (hscore)"
dodoc history doc/MANUAL_DE || die "dodoc failed"
dohtml doc/manual_de.html || die "dohtml failed"
+ newicon g2icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Gunocide II EX"
prepgamesdirs
}