summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-05-13 00:23:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-05-13 00:23:30 +0000
commit3f82c845ac6d2638cbd15993688556e6b303a80d (patch)
tree00ed46e3f9bf4b1f36abb5ee1beac01bb8fd7bcb /games-arcade/solarwolf/solarwolf-1.5.ebuild
parentStable on ppc; bug #91737 (again). (diff)
downloadhistorical-3f82c845ac6d2638cbd15993688556e6b303a80d.tar.gz
historical-3f82c845ac6d2638cbd15993688556e6b303a80d.tar.bz2
historical-3f82c845ac6d2638cbd15993688556e6b303a80d.zip
clean old versions and files; tidy
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-arcade/solarwolf/solarwolf-1.5.ebuild')
-rw-r--r--games-arcade/solarwolf/solarwolf-1.5.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/games-arcade/solarwolf/solarwolf-1.5.ebuild b/games-arcade/solarwolf/solarwolf-1.5.ebuild
index eb8a195af3fe..d54515cf932e 100644
--- a/games-arcade/solarwolf/solarwolf-1.5.ebuild
+++ b/games-arcade/solarwolf/solarwolf-1.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.5.ebuild,v 1.6 2005/05/12 17:48:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.5.ebuild,v 1.7 2005/05/13 00:23:30 mr_bones_ Exp $
-inherit games
+inherit eutils games
DESCRIPTION="action/arcade recreation of SolarFox"
HOMEPAGE="http://www.pygame.org/shredwheat/solarwolf/"
@@ -19,7 +19,7 @@ DEPEND=">=dev-python/pygame-1.5.6
src_unpack() {
unpack ${A}
- find "${S}" -name .xvpics -print0 | xargs -0 rm -r
+ find "${S}" -name .xvpics -print0 | xargs -0 rm -fr
}
src_install() {
@@ -27,9 +27,8 @@ src_install() {
doman dist/solarwolf.6.gz
dodir "${GAMES_LIBDIR}/${PN}"
cp -r code/ data/ *py "${D}/${GAMES_LIBDIR}/${PN}/" || die "cp failed"
- games_make_wrapper solarwolf "python ./solarwolf.py" ${GAMES_LIBDIR}/${PN}
- insinto /usr/share/icons
- doins dist/solarwolf.png
+ games_make_wrapper solarwolf "python ./solarwolf.py" "${GAMES_LIBDIR}/${PN}"
+ doicon dist/solarwolf.png
make_desktop_entry solarwolf
prepgamesdirs
}