summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-12 01:52:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-12 01:52:47 +0000
commitaec9983ddcb4cba8d7f2b65aed1bcdc7f66489c7 (patch)
tree281770cd933993b0a0cf286bc3a1900812519ea4 /games-arcade/supertux
parentMoved to games-arcade (diff)
downloadhistorical-aec9983ddcb4cba8d7f2b65aed1bcdc7f66489c7.tar.gz
historical-aec9983ddcb4cba8d7f2b65aed1bcdc7f66489c7.tar.bz2
historical-aec9983ddcb4cba8d7f2b65aed1bcdc7f66489c7.zip
Moved to games-arcade
Diffstat (limited to 'games-arcade/supertux')
-rw-r--r--games-arcade/supertux/Manifest4
-rw-r--r--games-arcade/supertux/files/digest-supertux-0.0.41
-rw-r--r--games-arcade/supertux/supertux-0.0.4.ebuild40
3 files changed, 43 insertions, 2 deletions
diff --git a/games-arcade/supertux/Manifest b/games-arcade/supertux/Manifest
index 6aa5c4d848f1..211fbff0d56f 100644
--- a/games-arcade/supertux/Manifest
+++ b/games-arcade/supertux/Manifest
@@ -1,3 +1,3 @@
-MD5 0b49f0e0c04bf17b097daa098d998d03 supertux-0.0.4.ebuild 1046
-MD5 f6151e077e21d10573a8fda4cf588966 ChangeLog 396
+MD5 fe39d06ae75d223e10dea355b9b8aefc ChangeLog 399
+MD5 0b61b51c227c16136cd06492dc171245 supertux-0.0.4.ebuild 1049
MD5 0a3308841e7c1506171ef6285d6129e3 files/digest-supertux-0.0.4 67
diff --git a/games-arcade/supertux/files/digest-supertux-0.0.4 b/games-arcade/supertux/files/digest-supertux-0.0.4
new file mode 100644
index 000000000000..bf69d90ceadb
--- /dev/null
+++ b/games-arcade/supertux/files/digest-supertux-0.0.4
@@ -0,0 +1 @@
+MD5 54f95a7fe1133587ac56c6980c2a79df supertux-0.0.4.tar.gz 1348474
diff --git a/games-arcade/supertux/supertux-0.0.4.ebuild b/games-arcade/supertux/supertux-0.0.4.ebuild
new file mode 100644
index 000000000000..6a9ea106e5f6
--- /dev/null
+++ b/games-arcade/supertux/supertux-0.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/supertux-0.0.4.ebuild,v 1.1 2003/09/12 01:52:45 msterret Exp $
+
+inherit games
+
+DESCRIPTION="A game similar to Super Mario Bros."
+SRC_URI="ftp://ftp.sonic.net/pub/users/nbs/unix/x/supertux/src/${P}.tar.gz"
+HOMEPAGE="http://www.newbreedsoftware.com/supertux/"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=media-libs/libsdl-1.1.5
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-mixer-1.2.4"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "/^DATA_PREFIX=/ s:=.*:=${GAMES_DATADIR}/${PN}/:" \
+ -e "/^JOY=/ s/YES/NO/" \
+ -e "s:-O2:${CFLAGS}:" Makefile || \
+ die "sed Makefile failed"
+
+ rm -rf data/images/shared/.xvpics
+}
+
+src_install() {
+ dogamesbin supertux
+ dodir ${GAMES_DATADIR}/${PN}
+ cp -r data/{images,sounds,music,levels} ${D}/${GAMES_DATADIR}/${PN}/
+ dodoc {AUTHORS,CHANGES,INSTALL,README,TODO}.txt
+ prepgamesdirs
+}