summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
commit2d06451b949706e2e14d1e9cdbdedf30613ca779 (patch)
treee4defbc5a7848f65ff263eb968fe9f97f4e1a5f1 /games-arcade/xgalaga
parentaction games ! (diff)
downloadhistorical-2d06451b949706e2e14d1e9cdbdedf30613ca779.tar.gz
historical-2d06451b949706e2e14d1e9cdbdedf30613ca779.tar.bz2
historical-2d06451b949706e2e14d1e9cdbdedf30613ca779.zip
arcade games !
Diffstat (limited to 'games-arcade/xgalaga')
-rw-r--r--games-arcade/xgalaga/ChangeLog32
-rw-r--r--games-arcade/xgalaga/Manifest3
-rw-r--r--games-arcade/xgalaga/files/digest-xgalaga-2.0.34-r42
-rw-r--r--games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild44
4 files changed, 81 insertions, 0 deletions
diff --git a/games-arcade/xgalaga/ChangeLog b/games-arcade/xgalaga/ChangeLog
new file mode 100644
index 000000000000..c985c36938c2
--- /dev/null
+++ b/games-arcade/xgalaga/ChangeLog
@@ -0,0 +1,32 @@
+# ChangeLog for app-games/xgalaga
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/ChangeLog,v 1.1 2003/09/10 19:29:22 vapier Exp $
+
+*xgalaga-2.0.34-r4 (25 Aug 2003)
+
+ 25 Aug 2003; Max Kalika <max@gentoo.org> xgalaga-2.0.34-r3.ebuild,
+ xgalaga-2.0.34-r4.ebuild:
+ Bump to version 2.0.34-r4 (patch version -27 because -21 isn't available
+ anymore). Other miscelleneous cleanups.
+
+*xgalaga-2.0.34-r3 (23 Dec 2002)
+
+ 23 Dec 2002; Seemant Kulleen <seemant@gentoo.org> xgalaga-2.0.34-r3.ebuild
+ files/digest-xgalaga-2.0.34-r3 :
+
+ Debian's patch fixes a LOT of issues including the annoying numlock bug --
+ keys won't work (can't fire or enter name at high score) with numlock on.
+ Fixes bug #7615 by decibelshelp@charter.net (David)
+
+*xgalaga-2.0.34-r2 (1 Feb 2002)
+
+ 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> xgalaga-2.0.34-r2.ebuild :
+ Added LICENSE, KEYWORDS.
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/games-arcade/xgalaga/Manifest b/games-arcade/xgalaga/Manifest
new file mode 100644
index 000000000000..6880b7069baf
--- /dev/null
+++ b/games-arcade/xgalaga/Manifest
@@ -0,0 +1,3 @@
+MD5 c5763d408eb45308448ffbcf4fcf817f xgalaga-2.0.34-r4.ebuild 1145
+MD5 ca8cc0202c14294ff39b62a624348104 ChangeLog 1396
+MD5 2b50109bab28e73cc2ef0e628e72ac1b files/digest-xgalaga-2.0.34-r4 140
diff --git a/games-arcade/xgalaga/files/digest-xgalaga-2.0.34-r4 b/games-arcade/xgalaga/files/digest-xgalaga-2.0.34-r4
new file mode 100644
index 000000000000..cc92dce59a7b
--- /dev/null
+++ b/games-arcade/xgalaga/files/digest-xgalaga-2.0.34-r4
@@ -0,0 +1,2 @@
+MD5 9f7ee685e9c4741b5f0edc3f91df9510 xgalaga_2.0.34.orig.tar.gz 314189
+MD5 3999ec19bb5d3eb1e1860b31cdd07bca xgalaga_2.0.34-27.diff.gz 44359
diff --git a/games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild b/games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild
new file mode 100644
index 000000000000..71ea88a0edd2
--- /dev/null
+++ b/games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xgalaga/xgalaga-2.0.34-r4.ebuild,v 1.1 2003/09/10 19:29:22 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Galaga game clone."
+HOMEPAGE="http://rumsey.org/xgal.html"
+SRC_URI="http://http.us.debian.org/debian/pool/main/x/${PN}/${PN}_${PV}.orig.tar.gz
+ http://http.us.debian.org/debian/pool/main/x/${PN}/${PN}_${PV}-27.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="virtual/x11"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+ epatch "${WORKDIR}/${PN}_${PV}-27.diff"
+}
+
+src_compile() {
+ econf --prefix=/usr/share/xgalaga --bindir=/usr/bin
+ emake CPPFLAGS="-D__NO_STRING_INLINES" || die "compile problem"
+}
+
+src_install () {
+ dobin xgalaga
+ dodoc README README.SOUND CHANGES COPYING INSTALL
+
+ insinto /usr/share/xgalaga/sounds
+ doins sounds/*.raw
+
+ insinto /usr/share/xgalaga/levels
+ doins levels/*.xgl
+
+ exeinto /usr/share/xgalaga
+ doexe xgal.sndsrv.linux
+
+ touch "${D}/usr/share/xgalaga/scores"
+ fperms 660 /usr/share/xgalaga/scores
+ fowners games:games /usr/share/xgalaga/scores
+}