summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-29 08:43:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-29 08:43:52 +0000
commitda6c116a9032486c3663da19964297863edfa2b1 (patch)
tree2f4a7ee6fdcb5603fc0bd32a29709055ace4a96a /games-arcade
parentdesktop icon (diff)
downloadhistorical-da6c116a9032486c3663da19964297863edfa2b1.tar.gz
historical-da6c116a9032486c3663da19964297863edfa2b1.tar.bz2
historical-da6c116a9032486c3663da19964297863edfa2b1.zip
add desktop entry
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/solarwolf/solarwolf-1.4.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/games-arcade/solarwolf/solarwolf-1.4.ebuild b/games-arcade/solarwolf/solarwolf-1.4.ebuild
index 57a58a4c572f..7488ed5c65bd 100644
--- a/games-arcade/solarwolf/solarwolf-1.4.ebuild
+++ b/games-arcade/solarwolf/solarwolf-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.4.ebuild,v 1.2 2004/01/29 07:07:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.4.ebuild,v 1.3 2004/01/29 08:43:52 vapier Exp $
inherit games
@@ -8,10 +8,9 @@ DESCRIPTION="action/arcade recreation of SolarFox"
HOMEPAGE="http://www.pygame.org/shredwheat/solarwolf/"
SRC_URI="http://www.pygame.org/shredwheat/solarwolf/${P}.tar.gz"
-KEYWORDS="x86 sparc"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE=""
+KEYWORDS="x86 sparc"
DEPEND=">=dev-python/pygame-1.5.6
>=dev-lang/python-2.3
@@ -23,9 +22,12 @@ src_unpack() {
}
src_install() {
- dodoc readme.txt || die "dodoc failed"
- dodir "${GAMES_LIBDIR}/${PN}"
- cp -r code/ data/ *py "${D}/${GAMES_LIBDIR}/${PN}/" || die "cp failed"
- games_make_wrapper solarwolf "python ./solarwolf.py" "${GAMES_LIBDIR}/${PN}"
+ dodoc readme.txt
+ dodir ${GAMES_LIBDIR}/${PN}
+ cp -r code/ data/ *py ${D}/${GAMES_LIBDIR}/${PN}/ || die "cp failed"
+ games_make_wrapper solarwolf "python ./solarwolf.py" ${GAMES_LIBDIR}/${PN}
+ insinto /usr/share/icons
+ doins ${FILESDIR}/solarwolf.png
+ make_desktop_entry solarwolf
prepgamesdirs
}