summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2008-03-18 01:15:38 +0000
committerTristan Heaven <tristan@gentoo.org>2008-03-18 01:15:38 +0000
commitf86d727f2d37d3a5aa963d942da144a06953d9c3 (patch)
treed95ab4e323bdf66262fb3f5820ee1d478f0fcd57 /games-board/blokish/blokish-0.9.4-r1.ebuild
parentUse wxGTK 2.8 instead of 2.6 (diff)
downloadhistorical-f86d727f2d37d3a5aa963d942da144a06953d9c3.tar.gz
historical-f86d727f2d37d3a5aa963d942da144a06953d9c3.tar.bz2
historical-f86d727f2d37d3a5aa963d942da144a06953d9c3.zip
Use wxGTK 2.8 instead of 2.6
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'games-board/blokish/blokish-0.9.4-r1.ebuild')
-rw-r--r--games-board/blokish/blokish-0.9.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-board/blokish/blokish-0.9.4-r1.ebuild b/games-board/blokish/blokish-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..977e0eea9877
--- /dev/null
+++ b/games-board/blokish/blokish-0.9.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/blokish-0.9.4-r1.ebuild,v 1.1 2008/03/18 01:15:38 nyhm Exp $
+
+inherit eutils wxwidgets games
+
+MY_P="${PN}_v${PV}"
+DESCRIPTION="Open source clone of the four-player board game Blokus"
+HOMEPAGE="http://sourceforge.net/projects/blokish/"
+SRC_URI="mirror://sourceforge/blokish/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=x11-libs/wxGTK-2.8*
+ virtual/opengl"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ WX_GTK_VER=2.8 need-wxwidgets unicode
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s:wx-config:${WX_CONFIG}:" \
+ configure makefile.in \
+ || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/${PN}.xpm
+ make_desktop_entry ${PN} Blokish ${PN}
+
+ dodoc AUTHORS ChangeLog README
+ dohtml docs/*
+ prepgamesdirs
+}