summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 17:46:27 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 17:46:27 +0000
commitfb8c4cf310fc6a66ecddbe48c1b77a183baa6141 (patch)
tree179b6d7697d589a3888e34ab007a4d76082e89ee /games-board/cgoban2
parentChanges to make the eclass more flexible (diff)
downloadhistorical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.tar.gz
historical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.tar.bz2
historical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.zip
board board games
Diffstat (limited to 'games-board/cgoban2')
-rw-r--r--games-board/cgoban2/ChangeLog14
-rw-r--r--games-board/cgoban2/Manifest5
-rw-r--r--games-board/cgoban2/cgoban2-2.4.61.ebuild33
-rw-r--r--games-board/cgoban2/cgoban2-2.5.1.ebuild33
-rw-r--r--games-board/cgoban2/files/digest-cgoban2-2.4.611
-rw-r--r--games-board/cgoban2/files/digest-cgoban2-2.5.11
6 files changed, 87 insertions, 0 deletions
diff --git a/games-board/cgoban2/ChangeLog b/games-board/cgoban2/ChangeLog
new file mode 100644
index 000000000000..1ff1045352de
--- /dev/null
+++ b/games-board/cgoban2/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for app-games/cgoban2
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/cgoban2/ChangeLog,v 1.1 2003/09/10 17:46:27 vapier Exp $
+
+*cgoban2-2.5.1 (17 Jul 2003)
+
+ 17 Jul 2003; Michael Sterrett <msterret@gentoo.org> cgoban2-2.5.1.ebuild:
+ version bump (bug 24663)
+
+*cgoban2-2.4.61 (10 Jul 2003)
+
+ 10 Jul 2003; Michael Sterrett <msterret@gentoo.org> cgoban2-2.4.61.ebuild:
+ initial commit. ebuild based on one provided by TGL (bug 15840)
+
diff --git a/games-board/cgoban2/Manifest b/games-board/cgoban2/Manifest
new file mode 100644
index 000000000000..c72f4302a90d
--- /dev/null
+++ b/games-board/cgoban2/Manifest
@@ -0,0 +1,5 @@
+MD5 4828356df2ba94b99b03a445130eefaf files/digest-cgoban2-2.4.61 71
+MD5 37a97ab008e09ff0c6ff2f31153974a2 files/digest-cgoban2-2.5.1 70
+MD5 c881c35a9f975b610bf52371501f39e6 ChangeLog 528
+MD5 83cabe0663ae099db2309718981995bb cgoban2-2.4.61.ebuild 783
+MD5 d3a2698c848e13df3acad9cb40a64c4d cgoban2-2.5.1.ebuild 782
diff --git a/games-board/cgoban2/cgoban2-2.4.61.ebuild b/games-board/cgoban2/cgoban2-2.4.61.ebuild
new file mode 100644
index 000000000000..d5f25c141b36
--- /dev/null
+++ b/games-board/cgoban2/cgoban2-2.4.61.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/cgoban2/cgoban2-2.4.61.ebuild,v 1.1 2003/09/10 17:46:27 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A Java client for the Kiseido Go Server, and a SGF editor"
+HOMEPAGE="http://kgs.kiseido.com/"
+SRC_URI="http://kgs.kiseido.com/cgoban-unix-${PV}.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND=">=virtual/jre-1.3
+ virtual/x11"
+
+S=${WORKDIR}/cgoban
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed \
+ -e 's;_DIR=.;_DIR='"${GAMES_DATADIR}/${PN}"';' \
+ < cgoban.sh.in > cgoban2 || die "sed cgoban.sh.in failed"
+}
+
+src_install() {
+ dogamesbin cgoban2
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins cgoban.jar
+ prepgamesdirs
+}
diff --git a/games-board/cgoban2/cgoban2-2.5.1.ebuild b/games-board/cgoban2/cgoban2-2.5.1.ebuild
new file mode 100644
index 000000000000..e7d64b8a50bd
--- /dev/null
+++ b/games-board/cgoban2/cgoban2-2.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/cgoban2/cgoban2-2.5.1.ebuild,v 1.1 2003/09/10 17:46:27 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A Java client for the Kiseido Go Server, and a SGF editor"
+HOMEPAGE="http://kgs.kiseido.com/"
+SRC_URI="http://kgs.kiseido.com/cgoban-unix-${PV}.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND=">=virtual/jre-1.3
+ virtual/x11"
+
+S=${WORKDIR}/cgoban
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed \
+ -e 's;_DIR=.;_DIR='"${GAMES_DATADIR}/${PN}"';' \
+ < cgoban.sh.in > cgoban2 || die "sed cgoban.sh.in failed"
+}
+
+src_install() {
+ dogamesbin cgoban2
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins cgoban.jar
+ prepgamesdirs
+}
diff --git a/games-board/cgoban2/files/digest-cgoban2-2.4.61 b/games-board/cgoban2/files/digest-cgoban2-2.4.61
new file mode 100644
index 000000000000..b3b539e7433a
--- /dev/null
+++ b/games-board/cgoban2/files/digest-cgoban2-2.4.61
@@ -0,0 +1 @@
+MD5 8440400400a2e0bc8f37086e5dc9d7e6 cgoban-unix-2.4.61.tar.bz2 863301
diff --git a/games-board/cgoban2/files/digest-cgoban2-2.5.1 b/games-board/cgoban2/files/digest-cgoban2-2.5.1
new file mode 100644
index 000000000000..38e989d940ce
--- /dev/null
+++ b/games-board/cgoban2/files/digest-cgoban2-2.5.1
@@ -0,0 +1 @@
+MD5 6928a4614450a338a595457d93209461 cgoban-unix-2.5.1.tar.bz2 780620