summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-10-18 03:02:54 +0000
committerDon Seiler <rizzo@gentoo.org>2005-10-18 03:02:54 +0000
commit6e1def0122091faef936a03604f120e85b24b95d (patch)
tree13e65465d447e52e78bf949158a8d89f7661a4da /games-board/pio
parentMark 2.4.5 stable on alpha (diff)
downloadhistorical-6e1def0122091faef936a03604f120e85b24b95d.tar.gz
historical-6e1def0122091faef936a03604f120e85b24b95d.tar.bz2
historical-6e1def0122091faef936a03604f120e85b24b95d.zip
Version bump
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'games-board/pio')
-rw-r--r--games-board/pio/ChangeLog7
-rw-r--r--games-board/pio/Manifest8
-rw-r--r--games-board/pio/files/digest-pio-0.9.331
-rw-r--r--games-board/pio/pio-0.9.33.ebuild51
4 files changed, 63 insertions, 4 deletions
diff --git a/games-board/pio/ChangeLog b/games-board/pio/ChangeLog
index 37bd33489032..1372674c0ebd 100644
--- a/games-board/pio/ChangeLog
+++ b/games-board/pio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/pio
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pio/ChangeLog,v 1.4 2005/10/13 05:01:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pio/ChangeLog,v 1.5 2005/10/18 03:02:54 rizzo Exp $
+
+*pio-0.9.33 (18 Oct 2005)
+
+ 18 Oct 2005; Don Seiler <rizzo@gentoo.org> +pio-0.9.33.ebuild:
+ Version bump
*pio-0.9.23 (18 Aug 2005)
diff --git a/games-board/pio/Manifest b/games-board/pio/Manifest
index 8d59e2f0facc..ce449dfb4993 100644
--- a/games-board/pio/Manifest
+++ b/games-board/pio/Manifest
@@ -1,6 +1,8 @@
+MD5 d02de909582ad3ef50aff4e096d0ce5d pio-0.9.19.ebuild 1110
MD5 7035b4db1ed5ed0e55ee3dd6524e5b2b metadata.xml 321
MD5 4a2092784b8521003ff632cf3b614cae pio-0.9.23.ebuild 1127
-MD5 d02de909582ad3ef50aff4e096d0ce5d pio-0.9.19.ebuild 1110
-MD5 545e3f1550aa703d0d3544872b900179 ChangeLog 493
-MD5 bd0fefda62535dc61a6c2791b5b194f8 files/digest-pio-0.9.23 68
+MD5 f45f96d8b37f860363ce666701b24301 ChangeLog 597
+MD5 3e421777d59bc01c0906697f3e06da96 pio-0.9.33.ebuild 1123
MD5 a270a5b020f0b2c049fe47b0396bafd9 files/digest-pio-0.9.19 68
+MD5 bd0fefda62535dc61a6c2791b5b194f8 files/digest-pio-0.9.23 68
+MD5 1aa79202dcebe05379ba182e2f361d44 files/digest-pio-0.9.33 68
diff --git a/games-board/pio/files/digest-pio-0.9.33 b/games-board/pio/files/digest-pio-0.9.33
new file mode 100644
index 000000000000..8853bd4dce54
--- /dev/null
+++ b/games-board/pio/files/digest-pio-0.9.33
@@ -0,0 +1 @@
+MD5 02b44c636f5c95ddc49004fd49efadd9 pioneers-0.9.33.tar.gz 2117400
diff --git a/games-board/pio/pio-0.9.33.ebuild b/games-board/pio/pio-0.9.33.ebuild
new file mode 100644
index 000000000000..c9317095d8f8
--- /dev/null
+++ b/games-board/pio/pio-0.9.33.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pio/pio-0.9.33.ebuild,v 1.1 2005/10/18 03:02:54 rizzo Exp $
+
+inherit eutils gnome2 debug
+
+MY_P="pioneers-${PV}"
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://pio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pio/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="nls debug X"
+
+RDEPEND=">=dev-libs/glib-2.4
+ >=gnome-base/libgnome-2.10
+ X? ( >=x11-libs/gtk+-2.4
+ >=app-text/scrollkeeper-0.3 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ export G2CONF="${G2CONF} `use_enable nls`"
+ export G2CONF="${G2CONF} `use_enable debug`"
+
+ if use X ; then
+ gnome2_src_compile
+ else
+ einfo
+ einfo "Only building console server"
+ einfo
+
+ econf ${G2CONF} || die "./configure failure"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README TODO NEWS"
+ if use X ; then
+ gnome2_src_install
+ else
+ make DESTDIR=${D} install
+ dodoc ${DOCS}
+ fi
+}