summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2004-06-12 20:13:55 +0000
committerTony Vroon <chainsaw@gentoo.org>2004-06-12 20:13:55 +0000
commitd638b577cbe481ea2485af95c4357f016342791b (patch)
treeeb5d0d985d9760e9f143e366ddcb0ec2c4f1470f /games-emulation/openmsx/openmsx-0.4.0.ebuild
parentFix previous commit. (diff)
downloadhistorical-d638b577cbe481ea2485af95c4357f016342791b.tar.gz
historical-d638b577cbe481ea2485af95c4357f016342791b.tar.bz2
historical-d638b577cbe481ea2485af95c4357f016342791b.zip
Version bump to 0.4.0, with two patches to control the new build system.
Diffstat (limited to 'games-emulation/openmsx/openmsx-0.4.0.ebuild')
-rw-r--r--games-emulation/openmsx/openmsx-0.4.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-emulation/openmsx/openmsx-0.4.0.ebuild b/games-emulation/openmsx/openmsx-0.4.0.ebuild
new file mode 100644
index 000000000000..01fe40abafe2
--- /dev/null
+++ b/games-emulation/openmsx/openmsx-0.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.4.0.ebuild,v 1.1 2004/06/12 20:13:55 chainsaw Exp $
+
+inherit games flag-o-matic
+
+DESCRIPTION="MSX emulator that aims for perfection"
+HOMEPAGE="http://openmsx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+
+RDEPEND="dev-lang/tcl
+ dev-libs/libxml2
+ media-libs/libpng
+ sys-libs/zlib
+ media-libs/sdl-image
+ media-libs/libsdl
+ virtual/x11
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-custom.mk.patch
+ epatch ${FILESDIR}/${P}-symlinking.patch
+}
+
+src_compile() {
+ # fix bug 32745
+ replace-flags -Os -O2
+ egamesconf || die "Fatal error in configure script"
+ emake || die "Fatal error during compilation"
+}
+
+src_install() {
+ egamesinstall OPENMSX_INSTALL="${D}/usr/games/openmsx" || die "Fatal error during installation"
+
+ dodoc README AUTHORS
+ dohtml -r doc/*
+
+ # Tidy up install
+ rm -f ${D}${GAMES_DATADIR}/openmsx/*.{txt,tex,html,png,css}
+
+ prepgamesdirs
+}