summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-06-19 20:28:38 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-06-19 20:28:38 +0000
commit0687f6723f68620d0caa7d51e3e83965c11c3461 (patch)
tree7169133e46eb1b4f5bf92b937ee01752f6b47919 /games-fps/quake1-textures/quake1-textures-20050820.ebuild
parentRemoved xine USE flag until x11-plugins/matchbox-desktop-xine is ready, bug #... (diff)
downloadhistorical-0687f6723f68620d0caa7d51e3e83965c11c3461.tar.gz
historical-0687f6723f68620d0caa7d51e3e83965c11c3461.tar.bz2
historical-0687f6723f68620d0caa7d51e3e83965c11c3461.zip
Version bump. Updated ebuild submitted by Radek Podgorny <radek@podgorny.cz> and edited by Paul Bredbury <brebs@sent.com>. Closing bug #108133.
Package-Manager: portage-2.1
Diffstat (limited to 'games-fps/quake1-textures/quake1-textures-20050820.ebuild')
-rw-r--r--games-fps/quake1-textures/quake1-textures-20050820.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-fps/quake1-textures/quake1-textures-20050820.ebuild b/games-fps/quake1-textures/quake1-textures-20050820.ebuild
new file mode 100644
index 000000000000..f3f8ba94c8c0
--- /dev/null
+++ b/games-fps/quake1-textures/quake1-textures-20050820.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-textures/quake1-textures-20050820.ebuild,v 1.1 2006/06/19 20:28:38 wolf31o2 Exp $
+
+inherit eutils games
+
+MY_SKINS="SKINSbmodels-48files-4-23-05.zip"
+MY_TEXTURES="textures-486files-8-20-05.rar"
+
+DESCRIPTION="Collection of graphical improvements for Quake 1"
+HOMEPAGE="http://facelift.quakedev.com/"
+SRC_URI="http://facelift.quakedev.com/download/${MY_SKINS}
+ http://facelift.quakedev.com/download/${MY_TEXTURES}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ || (
+ app-arch/unrar
+ app-arch/rar )"
+
+S=${WORKDIR}
+dir=${GAMES_DATADIR}/quake1
+
+src_unpack() {
+ unpack ${A}
+
+ mv readme.txt skins.txt
+}
+
+src_install() {
+ insinto "${dir}"/id1/textures
+ doins -r *.tga \
+ || die "doins *.tga failed"
+
+ # Set up symlink, for the demo levels to include the textures
+ dosym "${dir}/id1/textures" "${dir}/demo/textures"
+
+ dodoc *.txt
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ einfo "Use a Quake 1 client (e.g. darkplaces) to take advantage of these."
+}