summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-02-15 01:24:16 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-02-15 01:24:16 +0000
commit08deb688423826ed2e07f25f76b27ad4bd4e762e (patch)
treed8d70a92e2bc949fdb4850e9e4625744b3eb2330 /games-fps/ut2003
parent"Q.A.: Path variable quoting. (diff)
downloadhistorical-08deb688423826ed2e07f25f76b27ad4bd4e762e.tar.gz
historical-08deb688423826ed2e07f25f76b27ad4bd4e762e.tar.bz2
historical-08deb688423826ed2e07f25f76b27ad4bd4e762e.zip
Fix quoting.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'games-fps/ut2003')
-rw-r--r--games-fps/ut2003/ChangeLog7
-rw-r--r--games-fps/ut2003/ut2003-2225-r4.ebuild13
2 files changed, 12 insertions, 8 deletions
diff --git a/games-fps/ut2003/ChangeLog b/games-fps/ut2003/ChangeLog
index 33e32e5dbf0b..3c1b43416b98 100644
--- a/games-fps/ut2003/ChangeLog
+++ b/games-fps/ut2003/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/ut2003
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ChangeLog,v 1.44 2007/03/12 15:28:47 genone Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ChangeLog,v 1.45 2008/02/15 01:17:36 wolf31o2 Exp $
+
+ 15 Feb 2008; Chris Gianelloni <wolf31o2@gentoo.org> ut2003-2225-r4.ebuild:
+ Fix quoting.
12 Mar 2007; Marius Mauch <genone@gentoo.org> ut2003-2225-r4.ebuild:
Replacing einfo with elog
diff --git a/games-fps/ut2003/ut2003-2225-r4.ebuild b/games-fps/ut2003/ut2003-2225-r4.ebuild
index 5ee893f9d90c..0a2da02e16c5 100644
--- a/games-fps/ut2003/ut2003-2225-r4.ebuild
+++ b/games-fps/ut2003/ut2003-2225-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ut2003-2225-r4.ebuild,v 1.12 2007/03/12 15:28:47 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2003/ut2003-2225-r4.ebuild,v 1.13 2008/02/15 01:17:36 wolf31o2 Exp $
inherit eutils games
@@ -32,13 +32,14 @@ src_unpack() {
}
src_install() {
- insinto ${dir}
+ insinto "${dir}"
games_make_wrapper ut2003 ./ut2003 "${dir}" "${dir}"
make_desktop_entry ut2003 "Unreal Tournament 2003" ut2003.xpm
+ # TODO: change this to use doexe/doins
# this brings our install up to the newest version
- cp -r ${S}/ut2003-lnx-2225/* ${Ddir} || die
+ cp -r "${S}"/ut2003-lnx-2225/* "${Ddir}" || die
prepgamesdirs
}
@@ -48,7 +49,7 @@ pkg_postinst() {
# here is where we check for the existence of a cdkey...
# if we don't find one, we ask the user for it
- if [[ -f ${dir}/System/cdkey ]] ; then
+ if [[ -f "${dir}"/System/cdkey ]] ; then
elog "A cdkey file is already present in ${dir}/System"
else
ewarn "You MUST run this before playing the game:"
@@ -88,7 +89,7 @@ pkg_config() {
if [[ "${CDKEY1}" == "${CDKEY2}" ]] ; then
echo "${CDKEY1}" | tr a-z A-Z > ${dir}/System/cdkey
einfo "Thank you!"
- chown games:games ${dir}/System/cdkey
+ chown games:games "${dir}"/System/cdkey
break
else
eerror "Your CD key entries do not match. Try again."