summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-10-22 16:44:40 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-10-22 16:44:40 +0000
commit6059845a9a5e64ee7996477fa8db8bfe6dd96188 (patch)
tree92916057edd1c7a2f6247fb1a572d00a035d5c04 /games-fps
parentMarked ~ppc-macos (bug #108598) (diff)
downloadhistorical-6059845a9a5e64ee7996477fa8db8bfe6dd96188.tar.gz
historical-6059845a9a5e64ee7996477fa8db8bfe6dd96188.tar.bz2
historical-6059845a9a5e64ee7996477fa8db8bfe6dd96188.zip
Initial import. Ebuild by me. This is for splitting up doom3 into an initial data portion and the patch portion, allowing for upgrades without having to pull out the CD media.
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doom3-data/ChangeLog12
-rw-r--r--games-fps/doom3-data/Manifest4
-rw-r--r--games-fps/doom3-data/doom3-data-1.1.1282.ebuild59
-rw-r--r--games-fps/doom3-data/files/digest-doom3-data-1.1.12820
-rw-r--r--games-fps/doom3-data/metadata.xml11
5 files changed, 86 insertions, 0 deletions
diff --git a/games-fps/doom3-data/ChangeLog b/games-fps/doom3-data/ChangeLog
new file mode 100644
index 000000000000..74671ca33f43
--- /dev/null
+++ b/games-fps/doom3-data/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for games-fps/doom3-data
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-data/ChangeLog,v 1.1 2005/10/22 16:44:40 wolf31o2 Exp $
+
+*doom3-data-1.1.1282 (22 Oct 2005)
+
+ 22 Oct 2005; Chris Gianelloni <wolf31o2@gentoo.org> +metadata.xml,
+ +doom3-data-1.1.1282.ebuild:
+ Initial import. Ebuild by me. This is for splitting up doom3 into an initial
+ data portion and the patch portion, allowing for upgrades without having to
+ pull out the CD media.
+
diff --git a/games-fps/doom3-data/Manifest b/games-fps/doom3-data/Manifest
new file mode 100644
index 000000000000..cff1ff2779cb
--- /dev/null
+++ b/games-fps/doom3-data/Manifest
@@ -0,0 +1,4 @@
+MD5 58201e8ed85791f6763d1107313f165b ChangeLog 534
+MD5 7fa6ec075b5e4d012e288676b34b19fe doom3-data-1.1.1282.ebuild 1348
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-doom3-data-1.1.1282 0
+MD5 c0c31e633eaaed2a501119d465d9cf70 metadata.xml 500
diff --git a/games-fps/doom3-data/doom3-data-1.1.1282.ebuild b/games-fps/doom3-data/doom3-data-1.1.1282.ebuild
new file mode 100644
index 000000000000..032a16f8f63e
--- /dev/null
+++ b/games-fps/doom3-data/doom3-data-1.1.1282.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3-data/doom3-data-1.1.1282.ebuild,v 1.1 2005/10/22 16:44:40 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Doom III - data portion"
+HOMEPAGE="http://www.doom3.com/"
+SRC_URI=""
+
+LICENSE="DOOM3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="nostrip"
+
+DEPEND="app-arch/bzip2
+ app-arch/tar"
+RDEPEND="games-fps/doom3"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ check_license DOOM3
+ cdrom_get_cds Setup/Data/base/pak002.pk4 \
+ Setup/Data/base/pak000.pk4 \
+ Setup/Data/base/pak003.pk4
+ games_pkg_setup
+}
+
+src_install() {
+ dodir ${dir}
+
+ einfo "Copying files from Disk 1..."
+ doins ${CDROM_ROOT}/Setup/Data/base/pak002.pk4 \
+ || die "copying pak002"
+ cdrom_load_next_cd
+ einfo "Copying files from Disk 2..."
+ doins ${CDROM_ROOT}/Setup/Data/base/pak00* \
+ || die "copying pak000 and pak001"
+ cdrom_load_next_cd
+ einfo "Copying files from Disk 3..."
+ doins ${CDROM_ROOT}/Setup/Data/base/pak00* \
+ || die "copying pak003 and pak004"
+
+ find ${Ddir} -exec touch '{}' \;
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "This is just the data portion of the game. You will need to emerge"
+ einfo "games-fps/doom3 to play the game."
+ echo
+}
diff --git a/games-fps/doom3-data/files/digest-doom3-data-1.1.1282 b/games-fps/doom3-data/files/digest-doom3-data-1.1.1282
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/games-fps/doom3-data/files/digest-doom3-data-1.1.1282
diff --git a/games-fps/doom3-data/metadata.xml b/games-fps/doom3-data/metadata.xml
new file mode 100644
index 000000000000..014b5dd07f0e
--- /dev/null
+++ b/games-fps/doom3-data/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+This is the data portion of the commercial Id Software game Doom III. This is
+commercial software and requires the purchase of Doom III from any retailer.
+This package copies files from the Doom III media and is interactive, in that
+regard. To play the game, you will still need games-fps/doom3 merged.
+</longdescription>
+</pkgmetadata>