summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2006-10-12 19:24:35 +0000
committerTristan Heaven <tristan@gentoo.org>2006-10-12 19:24:35 +0000
commitf2a185eb363e75532b0886d5e93d7e6ccf1704ca (patch)
tree11b7b8e35a3fe740f3e7aa393dbb0a9b9c2840f3 /games-misc/qlife
parentBlock older versions on ghc-6.6, latest version is fine. (diff)
downloadhistorical-f2a185eb363e75532b0886d5e93d7e6ccf1704ca.tar.gz
historical-f2a185eb363e75532b0886d5e93d7e6ccf1704ca.tar.bz2
historical-f2a185eb363e75532b0886d5e93d7e6ccf1704ca.zip
Version bump
Package-Manager: portage-2.1.2_pre2-r9
Diffstat (limited to 'games-misc/qlife')
-rw-r--r--games-misc/qlife/ChangeLog9
-rw-r--r--games-misc/qlife/files/digest-qlife-0.82
-rw-r--r--games-misc/qlife/files/digest-qlife-0.93
-rw-r--r--games-misc/qlife/qlife-0.9.ebuild43
4 files changed, 55 insertions, 2 deletions
diff --git a/games-misc/qlife/ChangeLog b/games-misc/qlife/ChangeLog
index 5a702a86a54a..050343d4c7a6 100644
--- a/games-misc/qlife/ChangeLog
+++ b/games-misc/qlife/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-misc/qlife
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/qlife/ChangeLog,v 1.4 2005/07/01 15:03:34 caleb Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/qlife/ChangeLog,v 1.5 2006/10/12 19:24:34 nyhm Exp $
+
+*qlife-0.9 (12 Oct 2006)
+
+ 12 Oct 2006; Tristan Heaven <nyhm@gentoo.org> +qlife-0.9.ebuild:
+ Version bump
01 Jul 2005; Caleb Tennis <caleb@gentoo.org> qlife-0.7.ebuild,
qlife-0.8.ebuild:
diff --git a/games-misc/qlife/files/digest-qlife-0.8 b/games-misc/qlife/files/digest-qlife-0.8
index a57489c65216..31ebe0a08d9b 100644
--- a/games-misc/qlife/files/digest-qlife-0.8
+++ b/games-misc/qlife/files/digest-qlife-0.8
@@ -1 +1,3 @@
MD5 e00be5aa4e8ab7f80b1c5fa083d6f33a qlife-0.8.tar.gz 34645
+RMD160 e2f77e49dd6b021223d3995fd0cda6b5fa66412b qlife-0.8.tar.gz 34645
+SHA256 ea573ff59608df9f8d8e99de0cb1d439d8427c9b490dc48fa8881fdfa1968815 qlife-0.8.tar.gz 34645
diff --git a/games-misc/qlife/files/digest-qlife-0.9 b/games-misc/qlife/files/digest-qlife-0.9
new file mode 100644
index 000000000000..30831d404d83
--- /dev/null
+++ b/games-misc/qlife/files/digest-qlife-0.9
@@ -0,0 +1,3 @@
+MD5 171f5ecd73a5caecc15c9aea09d0ada2 qlife-qt4-0.9.tar.gz 35007
+RMD160 87c4454a3c0207c6f3c03357e1e32c3e9dc47e7a qlife-qt4-0.9.tar.gz 35007
+SHA256 a1ceacb0bae9f2fe0c4cebb2fe71c540c9afc4fbb9704cb37fa53d102cf3b003 qlife-qt4-0.9.tar.gz 35007
diff --git a/games-misc/qlife/qlife-0.9.ebuild b/games-misc/qlife/qlife-0.9.ebuild
new file mode 100644
index 000000000000..e7fffe46a74c
--- /dev/null
+++ b/games-misc/qlife/qlife-0.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/qlife/qlife-0.9.ebuild,v 1.1 2006/10/12 19:24:34 nyhm Exp $
+
+inherit toolchain-funcs qt4 games
+
+MY_P=${PN}-qt4-${PV}
+DESCRIPTION="Simulates the classical Game of Life invented by John Conway"
+HOMEPAGE="http://personal.inet.fi/koti/rkauppila/projects/life/"
+SRC_URI="http://personal.inet.fi/koti/rkauppila/projects/life/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="$(qt4_min_version 4.1)"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "/setPath/s:patterns:${GAMES_DATADIR}/${PN}/patterns:" \
+ lifedialog.cpp || die "sed failed"
+}
+
+src_compile() {
+ qmake || die "qmake failed"
+ emake \
+ CXX=$(tc-getCXX) \
+ LINK=$(tc-getCXX) \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin qlife || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins patterns/* || die "doins failed"
+ dohtml *.html
+ dodoc About README
+ prepgamesdirs
+}