summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-20 07:50:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-20 07:50:29 +0000
commit9607f605709afd5c4962b36f4c764a68afcfd6f3 (patch)
tree4b13c83618b4fb39e0a1795c3947a7218476a2fc /games-mud/mcl/mcl-0.53.00.ebuild
parentdigest fix (diff)
downloadhistorical-9607f605709afd5c4962b36f4c764a68afcfd6f3.tar.gz
historical-9607f605709afd5c4962b36f4c764a68afcfd6f3.tar.bz2
historical-9607f605709afd5c4962b36f4c764a68afcfd6f3.zip
Add patch from Robert Gill via bug #58489 to enable mcl to be able to be used from the virtual console.
Diffstat (limited to 'games-mud/mcl/mcl-0.53.00.ebuild')
-rw-r--r--games-mud/mcl/mcl-0.53.00.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/games-mud/mcl/mcl-0.53.00.ebuild b/games-mud/mcl/mcl-0.53.00.ebuild
index 305c8141d908..f4d2444c055b 100644
--- a/games-mud/mcl/mcl-0.53.00.ebuild
+++ b/games-mud/mcl/mcl-0.53.00.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/mcl-0.53.00.ebuild,v 1.7 2004/06/24 23:00:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mcl/mcl-0.53.00.ebuild,v 1.8 2004/08/20 07:50:29 mr_bones_ Exp $
inherit eutils gnuconfig games
DESCRIPTION="A console MUD client scriptable in Perl and Python"
-SRC_URI="http://www.andreasen.org/mcl/dist/${P}-src.tar.gz"
HOMEPAGE="http://www.andreasen.org/mcl/"
+SRC_URI="http://www.andreasen.org/mcl/dist/${P}-src.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 amd64"
SLOT="0"
+KEYWORDS="x86 amd64"
IUSE="python perl"
RDEPEND="perl? ( dev-lang/perl )
@@ -20,27 +20,31 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/${P}-fPIC.patch
+ epatch "${FILESDIR}/${P}-fPIC.patch"
+ epatch "${FILESDIR}/${PV}-vc.patch"
sed -i \
-e "/MCL_LIBRARY_PATH/ s:/usr/lib/mcl:${GAMES_LIBDIR}/${PN}:" \
- h/mcl.h || die "sed h/mcl.h failed"
+ h/mcl.h \
+ || die "sed h/mcl.h failed"
+ gnuconfig_update
}
src_compile() {
- gnuconfig_update || die
-
- egamesconf `use_enable perl` `use_enable python` || die
+ egamesconf \
+ $(use_enable perl) \
+ $(use_enable python) \
+ || die
emake || die "emake failed"
}
src_install () {
- make INSTALL_ROOT=${D} install || die "make install failed"
+ make INSTALL_ROOT="${D}" install || die "make install failed"
dodoc \
- doc/{Changes,Chat,Embedded,Examples,Modules,Plugins,README,TODO} || \
- die "dodoc failed"
+ doc/{Changes,Chat,Embedded,Examples,Modules,Plugins,README,TODO} \
+ || die "dodoc failed"
dohtml doc/*html || die "dohtml failed"
prepgamesdirs
}