summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-07-06 00:27:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-07-06 00:27:28 +0000
commitc3604134d9a77ad16943c5bada1fa44246deb828 (patch)
treefbd18d751b79948455046a87280864addde69c23 /games-puzzle/hexamine/hexamine-0.2.1.ebuild
parentinstall missing client_global.h; fix PIC handling on amd64 (diff)
downloadhistorical-c3604134d9a77ad16943c5bada1fa44246deb828.tar.gz
historical-c3604134d9a77ad16943c5bada1fa44246deb828.tar.bz2
historical-c3604134d9a77ad16943c5bada1fa44246deb828.zip
version bump
Package-Manager: portage-2.1.1_pre2-r2
Diffstat (limited to 'games-puzzle/hexamine/hexamine-0.2.1.ebuild')
-rw-r--r--games-puzzle/hexamine/hexamine-0.2.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-puzzle/hexamine/hexamine-0.2.1.ebuild b/games-puzzle/hexamine/hexamine-0.2.1.ebuild
new file mode 100644
index 000000000000..e7a524724d21
--- /dev/null
+++ b/games-puzzle/hexamine/hexamine-0.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hexamine/hexamine-0.2.1.ebuild,v 1.1 2006/07/06 00:27:28 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Hexagonal Minesweeper"
+HOMEPAGE="http://sourceforge.net/projects/hexamine"
+SRC_URI="mirror://sourceforge/hexamine/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ dev-python/pygame"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Modify game data directory
+ sed -i \
+ -e "s:\`dirname \$0\`:${GAMES_DATADIR}/${PN}:" \
+ -e "s:\./hexamine:exec python &:" \
+ hexamine || die "sed failed"
+}
+
+src_install() {
+ dogamesbin hexamine || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r hexamine.* skins || die "doins failed"
+ dodoc ABOUT README
+ prepgamesdirs
+}