summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-25 07:09:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-25 07:09:15 +0000
commit903f351acc914d0ee1877d67bef99e7ac31e87b4 (patch)
treee9d0cc7c6efe2e7f494c333cfcb2e181d918e238 /games-puzzle/tint/tint-0.03a.ebuild
parentlets help the user (diff)
downloadhistorical-903f351acc914d0ee1877d67bef99e7ac31e87b4.tar.gz
historical-903f351acc914d0ee1877d67bef99e7ac31e87b4.tar.bz2
historical-903f351acc914d0ee1877d67bef99e7ac31e87b4.zip
initial commit - ebuild based on the one provided by LepeL via bug #65143
Diffstat (limited to 'games-puzzle/tint/tint-0.03a.ebuild')
-rw-r--r--games-puzzle/tint/tint-0.03a.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/tint/tint-0.03a.ebuild b/games-puzzle/tint/tint-0.03a.ebuild
new file mode 100644
index 000000000000..7056e28dcea4
--- /dev/null
+++ b/games-puzzle/tint/tint-0.03a.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tint/tint-0.03a.ebuild,v 1.1 2004/09/25 07:09:15 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P=${P/-/_}
+DESCRIPTION="Tint Is Not Tetris, a ncurses based clone of the original Tetris(tm) game"
+HOMEPAGE="http://oasis.frogfoot.net/code/tint/"
+SRC_URI="http://oasis.frogfoot.net/code/tint/download/$PV/$MY_P.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.4-r1"
+
+src_unpack() {
+ unpack $A
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-warnings.patch"
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ localstatedir="${GAMES_STATEDIR}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin tint || die "dogamesbin failed"
+ doman tint.6
+ dodoc CREDITS NOTES
+ insopts -m 0664
+ insinto "${GAMES_STATEDIR}"
+ doins tint.scores || die "doins failed"
+ prepgamesdirs
+}