summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-19 01:16:17 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-19 01:16:17 +0000
commit45f9640fdd8458cdc6a67afb5ac64f59bbd570bc (patch)
tree456115230563354d82d2ee4a150de6a1c11b7262 /games-puzzle/tod/tod-0.ebuild
parentFixed multilib-strict issue, bug 102562. (diff)
downloadhistorical-45f9640fdd8458cdc6a67afb5ac64f59bbd570bc.tar.gz
historical-45f9640fdd8458cdc6a67afb5ac64f59bbd570bc.tar.bz2
historical-45f9640fdd8458cdc6a67afb5ac64f59bbd570bc.zip
Initial import. Ebuild submitted by Dick Marinus #88492.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-puzzle/tod/tod-0.ebuild')
-rw-r--r--games-puzzle/tod/tod-0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-puzzle/tod/tod-0.ebuild b/games-puzzle/tod/tod-0.ebuild
new file mode 100644
index 000000000000..ebef393b625a
--- /dev/null
+++ b/games-puzzle/tod/tod-0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tod/tod-0.ebuild,v 1.1 2005/08/19 01:16:17 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Tetanus On Drugs simulates playing a Tetris clone under the influence of hallucinogenic drugs"
+HOMEPAGE="http://www.pineight.com/tod/"
+SRC_URI="http://www.pineight.com/pc/win${PN}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/allegro"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ sed -i \
+ -e "s:idltd\.dat:${GAMES_DATADIR}/${PN}/idltd.dat:" \
+ rec.c || die
+}
+
+src_compile() {
+ emake -f makefile || die "make failed"
+}
+
+src_install() {
+ newgamesbin tod-debug.exe tod || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins idltd.dat || die
+ dodoc readme.txt
+}