summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-13 07:50:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-13 07:50:05 +0000
commitf88f9dc2632d3397b9d6d12d379f2829b0196a69 (patch)
treee5f25c8d3dd4c558ce025581623b58f3491d2f14 /games-rpg
parentStable on mips, bug #84076 (diff)
downloadhistorical-f88f9dc2632d3397b9d6d12d379f2829b0196a69.tar.gz
historical-f88f9dc2632d3397b9d6d12d379f2829b0196a69.tar.bz2
historical-f88f9dc2632d3397b9d6d12d379f2829b0196a69.zip
cleaned up python library code in configure.in; added work-around for bug #83434 that caused a compile failure related to nls support; more deps for use doc; keepdir the directory that games that use adonthell will use
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/adonthell/ChangeLog10
-rw-r--r--games-rpg/adonthell/Manifest6
-rw-r--r--games-rpg/adonthell/adonthell-0.3.3-r1.ebuild34
-rw-r--r--games-rpg/adonthell/files/0.3.3-configure.in.patch85
4 files changed, 109 insertions, 26 deletions
diff --git a/games-rpg/adonthell/ChangeLog b/games-rpg/adonthell/ChangeLog
index bdf1d163aa26..69b2de93d1de 100644
--- a/games-rpg/adonthell/ChangeLog
+++ b/games-rpg/adonthell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/adonthell
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.5 2004/12/06 23:22:20 mr_bones_ Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.6 2005/03/13 07:50:05 mr_bones_ Exp $
+
+ 13 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ files/0.3.3-configure.in.patch, adonthell-0.3.3-r1.ebuild:
+ cleaned up python library code in configure.in; added work-around for bug
+ #83434 that caused a compile failure related to nls support; more deps for use
+ doc; keepdir the directory that games that use adonthell will use.
06 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org>
adonthell-0.3.3-r1.ebuild:
diff --git a/games-rpg/adonthell/Manifest b/games-rpg/adonthell/Manifest
index d566187bdcff..1e5f0ef70f71 100644
--- a/games-rpg/adonthell/Manifest
+++ b/games-rpg/adonthell/Manifest
@@ -1,5 +1,5 @@
-MD5 0b1d8697c0474b87a2567f82a99cf3e7 ChangeLog 1056
+MD5 70de9cd37cf0609a8f8c5c57a1a39028 ChangeLog 1399
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 fd32e71c82fb5e73e8b11f081054c3a1 adonthell-0.3.3-r1.ebuild 907
-MD5 6211b46f79a2bbaea936f30e64a83713 files/0.3.3-configure.in.patch 528
+MD5 bef65f10e9b0647e3d4fae949f791434 adonthell-0.3.3-r1.ebuild 1225
+MD5 f8819f0b8b8a019c2ab89d7c707665eb files/0.3.3-configure.in.patch 2957
MD5 e944f3812b6938f625c3a2bba14b3b35 files/digest-adonthell-0.3.3-r1 72
diff --git a/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild b/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild
index f6ca61aed8f7..04542d97e82c 100644
--- a/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild
+++ b/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild,v 1.8 2004/12/06 23:22:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.3-r1.ebuild,v 1.9 2005/03/13 07:50:05 mr_bones_ Exp $
-inherit games
+inherit eutils games
DESCRIPTION="roleplaying game engine"
HOMEPAGE="http://adonthell.linuxgames.com/"
@@ -10,19 +10,32 @@ SRC_URI="http://savannah.nongnu.org/download/adonthell/${PN}-src-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc ~amd64"
-IUSE="nls doc"
+KEYWORDS="~amd64 ppc x86"
+IUSE="doc"
-DEPEND="dev-lang/python
+RDEPEND="dev-lang/python
media-libs/libsdl
media-libs/libvorbis
media-libs/libogg
- sys-libs/zlib
- doc? ( app-doc/doxygen )"
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen )
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-configure.in.patch"
+ aclocal && automake -a && autoconf || die "autotools failed"
+}
src_compile() {
egamesconf \
- $(use_enable nls) \
+ --disable-dependency-tracking \
+ --disable-py-debug \
+ --enable-nls \
$(use_enable doc) \
|| die
touch doc/items/{footer,header}.html
@@ -31,6 +44,7 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS ChangeLog FULLSCREEN.howto NEWBIE NEWS
+ keepdir "${GAMES_DATADIR}/${PN}/games"
+ dodoc AUTHORS ChangeLog FULLSCREEN.howto INSTALL NEWBIE NEWS README
prepgamesdirs
}
diff --git a/games-rpg/adonthell/files/0.3.3-configure.in.patch b/games-rpg/adonthell/files/0.3.3-configure.in.patch
index ca6d5d1edcc5..fd7ad893772c 100644
--- a/games-rpg/adonthell/files/0.3.3-configure.in.patch
+++ b/games-rpg/adonthell/files/0.3.3-configure.in.patch
@@ -1,11 +1,74 @@
---- configure.in.orig 2003-03-10 19:34:50.000000000 -0800
-+++ configure.in 2003-03-10 19:35:31.000000000 -0800
-@@ -216,7 +216,7 @@
-
- if test x$haveldd != x ; then
- changequote(<<, >>)
-- py_deps=`ldd $PYPACKAGE | sed 's/\( *lib\([^\/]*\)\.so.*=.*$\)/-l\2/p; d'`
-+ py_deps=`ldd $PYPACKAGE | sed 's/\( *.*lib\([^\/]*\)\.so.*=.*$\)/-l\2/p; d' | grep -v sandbox`
- for py_lib in $py_deps ; do
- if test "$py_lib" != "-lm" && test "$py_lib" != "-lc" ; then
- PY_DEPS="$PY_DEPS $py_lib"
+--- configure.in.orig 2005-03-12 18:01:25.000000000 -0500
++++ configure.in 2005-03-13 00:12:26.000000000 -0500
+@@ -159,10 +159,8 @@
+
+ dnl Extract the version using Python, check against 1.5+
+
+- changequote(<<, >>)
+- PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version[0]) * 10 + int(sys.version[2]))'`
+- PY_VERSION=`$PYPACKAGE -c 'import sys ; print sys.version[0:3]'`
+- changequote([, ])
++ PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version@<:@0@:>@) * 10 + int(sys.version@<:@2@:>@))'`
++ PY_VERSION=`$PYPACKAGE -c 'import sys ; print sys.version@<:@0:3@:>@'`
+
+ if test $PYTHON_VERSION -lt 15; then
+ echo "Sorry, you need to have Python 1.5+ installed - update your version!"
+@@ -172,9 +170,7 @@
+ dnl Find the Python.h header file
+
+ AC_MSG_CHECKING(for Python header files)
+- changequote(<<, >>)
+- PYINCLUDE=`$PYPACKAGE -c 'import sys ; print "%s/include/python%s" % (sys.prefix, sys.version[:3])'`
+- changequote([, ])
++ PYINCLUDE=`$PYPACKAGE -c 'import sys ; print "%s/include/python%s" % (sys.prefix, sys.version@<:@:3@:>@)'`
+
+ if test -r "$PYINCLUDE/Python.h"; then
+ PY_CFLAGS="-I$PYINCLUDE"
+@@ -188,10 +184,8 @@
+
+ AC_MSG_CHECKING(for Python library)
+ PYLIB=""
+- changequote(<<, >>)
+ PYPREFIX=`$PYPACKAGE -c 'import sys; print sys.prefix'`
+- PYLIBVER=`$PYPACKAGE -c 'import sys; print sys.version[:3]'`
+- changequote([, ])
++ PYLIBVER=`$PYPACKAGE -c 'import sys; print sys.version@<:@:3@:>@'`
+
+ py_paths="$PYPREFIX/lib/python$PYLIBVER/config $PYPREFIX/lib"
+ py_suffix="$PYLIBVER.so $PYLIBVER.a .so .a"
+@@ -220,19 +214,9 @@
+
+ dnl Get the libraries that python depends on
+
+- AC_PATH_PROG(haveldd, ldd)
+ AC_MSG_CHECKING(for Python's dependencies)
+
+- if test x$haveldd != x ; then
+- changequote(<<, >>)
+- py_deps=`ldd $PYPACKAGE | sed 's/\( *.*lib\([^\/]*\)\.so.*=.*$\)/-l\2/p; d' | grep -v 'stdc++'`
+- for py_lib in $py_deps ; do
+- if test "$py_lib" != "-lm" && test "$py_lib" != "-lc" ; then
+- PY_DEPS="$PY_DEPS $py_lib"
+- fi
+- done
+- changequote([, ])
+- fi
++ PY_DEPS="$PY_DEPS `python-config --libs`"
+
+ case $target in
+ *-sun-solaris*)
+@@ -280,11 +264,9 @@
+ if test "$P_SWIG" != "no" ; then
+ $P_SWIG -version &> swig.ver
+
+- changequote(<<, >>)
+- swig_major_ver=`more swig.ver | sed 's/.* \([0-9]*\)\.[0-9]*\.[0-9]*.*/\1/p; d'`
+- swig_minor_ver=`more swig.ver | sed 's/.* [0-9]*\.\([0-9]*\)\.[0-9]*.*/\1/p; d'`
+- swig_micro_ver=`more swig.ver | sed 's/.* [0-9]*\.[0-9]*\.\([0-9]*\).*/\1/p; d'`
+- changequote([, ])
++ swig_major_ver=`more swig.ver | sed 's/.* \(@<:@0-9@:>@*\)\.@<:@0-9@:>@*\.@<:@0-9@:>@*.*/\1/p; d'`
++ swig_minor_ver=`more swig.ver | sed 's/.* @<:@0-9@:>@*\.\(@<:@0-9@:>@*\)\.@<:@0-9@:>@*.*/\1/p; d'`
++ swig_micro_ver=`more swig.ver | sed 's/.* @<:@0-9@:>@*\.@<:@0-9@:>@*\.\(@<:@0-9@:>@*\).*/\1/p; d'`
+
+ rm -f swig.ver
+