summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2007-07-25 09:27:29 +0000
committerChristian Faulhammer <fauli@gentoo.org>2007-07-25 09:27:29 +0000
commitfd582c372da6876efc7e64ae70508bd407ba300a (patch)
tree2256b6bb5e90baabe96d7022fc5a8e87e9e40b3d /games-simulation/fgrun/fgrun-0.4.8.ebuild
parentstable x86 (diff)
downloadhistorical-fd582c372da6876efc7e64ae70508bd407ba300a.tar.gz
historical-fd582c372da6876efc7e64ae70508bd407ba300a.tar.bz2
historical-fd582c372da6876efc7e64ae70508bd407ba300a.zip
keyworded ~x86, bug 186379; fixed detection of media-libs/plib
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'games-simulation/fgrun/fgrun-0.4.8.ebuild')
-rw-r--r--games-simulation/fgrun/fgrun-0.4.8.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/games-simulation/fgrun/fgrun-0.4.8.ebuild b/games-simulation/fgrun/fgrun-0.4.8.ebuild
index 1db08c153279..28f324eb62a6 100644
--- a/games-simulation/fgrun/fgrun-0.4.8.ebuild
+++ b/games-simulation/fgrun/fgrun-0.4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-0.4.8.ebuild,v 1.1 2007/04/26 06:16:18 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-0.4.8.ebuild,v 1.2 2007/07/25 09:27:29 opfer Exp $
inherit autotools eutils games
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="dev-games/simgear
@@ -26,6 +26,11 @@ src_unpack() {
AT_M4DIR=. eautoreconf
}
+src_compile() {
+ egamesconf --with-plib-libraries=/usr/$(get_libdir) --with-plib-includes=/usr/include || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS NEWS