summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-24 00:09:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-24 00:09:32 +0000
commit40389bcd8819b8ea2420fdbf8dde300868112c3c (patch)
tree13c1a636be764cb9e6d3f29cd2e97b1bab6826bc /games-strategy/asc/asc-1.15.0.0.ebuild
parentxine-lib needs at least -O1 optimization or it wont even compile ;D #31243 (diff)
downloadhistorical-40389bcd8819b8ea2420fdbf8dde300868112c3c.tar.gz
historical-40389bcd8819b8ea2420fdbf8dde300868112c3c.tar.bz2
historical-40389bcd8819b8ea2420fdbf8dde300868112c3c.zip
version bump (bug #54845)
Diffstat (limited to 'games-strategy/asc/asc-1.15.0.0.ebuild')
-rw-r--r--games-strategy/asc/asc-1.15.0.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-strategy/asc/asc-1.15.0.0.ebuild b/games-strategy/asc/asc-1.15.0.0.ebuild
new file mode 100644
index 000000000000..3e3906006c80
--- /dev/null
+++ b/games-strategy/asc/asc-1.15.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/asc-1.15.0.0.ebuild,v 1.1 2004/06/24 00:09:32 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="turn based strategy game designed in the tradition of the Battle Isle series"
+HOMEPAGE="http://www.asc-hq.org/"
+SRC_URI="mirror://sourceforge/asc-hq/asc-source-${PV}.tar.gz
+ http://www.asc-hq.org/frontiers.mp3
+ http://www.asc-hq.org/time_to_strike.mp3
+ http://www.asc-hq.org/machine_wars.mp3"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="virtual/glibc
+ app-arch/bzip2
+ >=media-libs/libsdl-1.2
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ >=media-libs/sdlmm-0.1.8
+ >=dev-libs/libsigc++-1.2
+ >=media-libs/paragui-1.0.1"
+DEPEND="${RDEPEND}
+ app-arch/zip"
+
+src_unpack() {
+ unpack ${A}
+ cp "${DISTDIR}/"*mp3 "${S}/data/music" || die "cp music failed"
+}
+
+src_compile() {
+ # Added --disable-paraguitest for bugs 26402 and 4488
+ egamesconf \
+ --datadir="${GAMES_DATADIR_BASE}" \
+ --disable-dependency-tracking \
+ --disable-paraguitest \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ dohtml -r doc/*
+ prepgamesdirs
+}