summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-05-16 17:15:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-05-16 17:15:58 +0000
commite1c11bc68b308ba71c26982c4d961abe2f4be239 (patch)
tree1b67cb00757750cb4fb19a021f0b8b9db8427975 /games-strategy
parentAdded cross-compile support. (diff)
downloadhistorical-e1c11bc68b308ba71c26982c4d961abe2f4be239.tar.gz
historical-e1c11bc68b308ba71c26982c4d961abe2f4be239.tar.bz2
historical-e1c11bc68b308ba71c26982c4d961abe2f4be239.zip
version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glob2/ChangeLog7
-rw-r--r--games-strategy/glob2/Manifest6
-rw-r--r--games-strategy/glob2/files/digest-glob2-0.8.151
-rw-r--r--games-strategy/glob2/glob2-0.8.15.ebuild40
4 files changed, 51 insertions, 3 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index fe534b3e84ca..cea6166ffb88 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/glob2
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.20 2005/01/30 03:25:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.21 2005/05/16 17:15:58 mr_bones_ Exp $
+
+*glob2-0.8.15 (16 May 2005)
+
+ 16 May 2005; Michael Sterrett <mr_bones_@gentoo.org> +glob2-0.8.15.ebuild:
+ version bump
29 Jan 2005; Michael Sterrett <mr_bones_@gentoo.org> -glob2-0.8.9.ebuild:
clean old ebuild
diff --git a/games-strategy/glob2/Manifest b/games-strategy/glob2/Manifest
index f1ee2d1d29da..1d50415872fe 100644
--- a/games-strategy/glob2/Manifest
+++ b/games-strategy/glob2/Manifest
@@ -1,7 +1,9 @@
-MD5 d7056a5200018662f7d3ea4d6ac2ab6d ChangeLog 2385
-MD5 9a94a412c5c15d8a6bf1e9a8656e1ffc glob2-0.8.10.ebuild 931
MD5 2655dc80bff941349ed9468bda24c5f3 glob2-0.8.11.ebuild 1273
+MD5 9a94a412c5c15d8a6bf1e9a8656e1ffc glob2-0.8.10.ebuild 931
MD5 be3faa436a456146cab34d1a7ba5e534 metadata.xml 546
+MD5 3b2c99f611b7830b4ac78af1a80f8a06 ChangeLog 2507
+MD5 a044cb78d115289d86e415f240ba75d5 glob2-0.8.15.ebuild 1032
MD5 de372c45a3d3c17421e28b07dbf1f49d files/digest-glob2-0.8.10 65
MD5 00b6b6b01afb0aa92162ea1485efcc86 files/digest-glob2-0.8.11 65
MD5 da2177e9535fd8deab07d52e847b30a4 files/glob2-0.8.11-configure_speex.patch 2173
+MD5 222d938fd35ab1fb95eaf828c73203d5 files/digest-glob2-0.8.15 65
diff --git a/games-strategy/glob2/files/digest-glob2-0.8.15 b/games-strategy/glob2/files/digest-glob2-0.8.15
new file mode 100644
index 000000000000..77ad7c09423f
--- /dev/null
+++ b/games-strategy/glob2/files/digest-glob2-0.8.15
@@ -0,0 +1 @@
+MD5 9adabb11048cd55c52822456b889b514 glob2-0.8.15.tar.gz 8990844
diff --git a/games-strategy/glob2/glob2-0.8.15.ebuild b/games-strategy/glob2/glob2-0.8.15.ebuild
new file mode 100644
index 000000000000..87829e7732dd
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.8.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.8.15.ebuild,v 1.1 2005/05/16 17:15:58 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
+HOMEPAGE="http://www.ysagoon.com/glob2/"
+SRC_URI="http://epfl.ysagoon.com/~glob2/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ >=media-libs/libsdl-1.2.0
+ media-libs/libpng
+ media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/libvorbis
+ >=media-libs/speex-1.1
+ =media-libs/freetype-2*
+ sys-libs/zlib"
+
+src_compile() {
+ #./configure assumes that vorbis will be installed under PREFIX bug #46352
+ egamesconf \
+ --with-vorbis=/usr \
+ --with-speex=/usr \
+ --with-speex-includes=/usr/include/speex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO
+ prepgamesdirs
+}