summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-05-04 18:47:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-05-04 18:47:19 +0000
commit3e6d953e8aca67da583ffaf7b06ea61bd5493493 (patch)
treea43c0b67427a507ca68bc826cb810bde2dbcaf6c /games-util/catcodec/catcodec-1.0.3.ebuild
parentChange mpich2 block to <1.4-rc2 (bug #145367) (diff)
downloadhistorical-3e6d953e8aca67da583ffaf7b06ea61bd5493493.tar.gz
historical-3e6d953e8aca67da583ffaf7b06ea61bd5493493.tar.bz2
historical-3e6d953e8aca67da583ffaf7b06ea61bd5493493.zip
version bump
Package-Manager: portage-2.1.9.42/cvs/Linux i686
Diffstat (limited to 'games-util/catcodec/catcodec-1.0.3.ebuild')
-rw-r--r--games-util/catcodec/catcodec-1.0.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-util/catcodec/catcodec-1.0.3.ebuild b/games-util/catcodec/catcodec-1.0.3.ebuild
new file mode 100644
index 000000000000..6e308016eaad
--- /dev/null
+++ b/games-util/catcodec/catcodec-1.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/catcodec/catcodec-1.0.3.ebuild,v 1.1 2011/05/04 18:47:19 mr_bones_ Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Decodes and encodes sample catalogues for OpenTTD"
+HOMEPAGE="http://www.openttd.org/en/download-catcodec"
+SRC_URI="http://binaries.openttd.org/extra/catcodec/${PV}/${P}-source.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+src_prepare() {
+ tc-export CXX
+}
+
+src_compile() {
+ emake VERBOSE=1 || die
+}
+
+src_install() {
+ dobin catcodec || die
+ dodoc changelog.txt docs/readme.txt
+ doman docs/catcodec.1
+}