summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-24 00:00:45 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-24 00:00:45 +0000
commitdb16c0b40ff2cd0260861976ad269177dfd67954 (patch)
tree4313db8f95678431524dc0d963bdccd4af674d12 /games-util
parentdont set EXTRA_EMAKE (diff)
downloadhistorical-db16c0b40ff2cd0260861976ad269177dfd67954.tar.gz
historical-db16c0b40ff2cd0260861976ad269177dfd67954.tar.bz2
historical-db16c0b40ff2cd0260861976ad269177dfd67954.zip
clean up ugly ebuild
Diffstat (limited to 'games-util')
-rw-r--r--games-util/loki_patch/Manifest12
-rw-r--r--games-util/loki_patch/loki_patch-20040916.ebuild25
2 files changed, 23 insertions, 14 deletions
diff --git a/games-util/loki_patch/Manifest b/games-util/loki_patch/Manifest
index cd511fb31d9b..dc7ec7ae3967 100644
--- a/games-util/loki_patch/Manifest
+++ b/games-util/loki_patch/Manifest
@@ -1,4 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 6e8a19978d7128410145f7b5b15ecf3b ChangeLog 467
-MD5 c8675f649430bd5157fd865766e6a998 loki_patch-20040916.ebuild 1028
+MD5 21bd6294b95aaee5b036007cd6c401a4 loki_patch-20040916.ebuild 918
MD5 11a7e1491b1ac042ac7216b26b4ad1fb metadata.xml 254
MD5 9a7f5741c12bca917a311213a179acff files/digest-loki_patch-20040916 72
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFBU2O5HTu7gpaalycRAhmhAKDZQ3vDsROG0uhkgi0aoyLuLgRRPQCg1jch
+cpCwpu3HjsIgCGMWxB2Egeg=
+=nWze
+-----END PGP SIGNATURE-----
diff --git a/games-util/loki_patch/loki_patch-20040916.ebuild b/games-util/loki_patch/loki_patch-20040916.ebuild
index 618f1f33076d..ff5a5aa94b8c 100644
--- a/games-util/loki_patch/loki_patch-20040916.ebuild
+++ b/games-util/loki_patch/loki_patch-20040916.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/loki_patch-20040916.ebuild,v 1.1 2004/09/21 22:40:09 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/loki_patch-20040916.ebuild,v 1.2 2004/09/24 00:00:45 vapier Exp $
inherit eutils
@@ -11,26 +11,25 @@ SRC_URI="http://dev.gentoo.org/~wolf31o2/sources/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-RESTRICT=""
IUSE=""
DEPEND="dev-util/xdelta
- dev-libs/libxml
- games-util/loki_setupdb"
+ dev-libs/libxml
+ games-util/loki_setupdb"
src_compile() {
./autogen.sh || die "autogen failed."
- EXTRA_ECONF="--with-setupdb=/usr/share/loki_setupdb"
- econf || die "econf failed."
- sed -i -e 's/\.\.\/loki_setupdb/\/usr\/share\/loki_setupdb/' \
- -e -e 's/-I$(SETUPDB)/-I$(SETUPDB)\/include/' Makefile
+ econf \
+ --with-setupdb=/usr/share/loki_setupdb \
+ || die "econf failed."
+ sed -i \
+ -e 's/\.\.\/loki_setupdb/\/usr\/share\/loki_setupdb/' \
+ -e 's/-I$(SETUPDB)/-I$(SETUPDB)\/include/' \
+ Makefile
emake || die "emake failed"
}
src_install() {
- # no DESTDIR-support in Makefile
- dodir /usr/bin
- exeinto /usr/bin
- doexe loki_patch make_patch || die "doexe failed."
- dodoc CHANGES NOTES README TODO || die "dodoc failed."
+ dobin loki_patch make_patch || die "doexe failed"
+ dodoc CHANGES NOTES README TODO
}