summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-05 17:42:37 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-05 17:42:37 +0000
commit06c9fa5403857e39e185e5bc432a8d4db4003f4e (patch)
treee285ffbb29849ffcf86d46a0007b7763c2dc9c93 /gnome-apps/mc
parentUpdate, thx seb (diff)
downloadhistorical-06c9fa5403857e39e185e5bc432a8d4db4003f4e.tar.gz
historical-06c9fa5403857e39e185e5bc432a8d4db4003f4e.tar.bz2
historical-06c9fa5403857e39e185e5bc432a8d4db4003f4e.zip
Added USE gnome,pam,slang
Diffstat (limited to 'gnome-apps/mc')
-rw-r--r--gnome-apps/mc/files/digest-mc-4.5.53-r11
-rw-r--r--gnome-apps/mc/mc-4.5.53-r1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/gnome-apps/mc/files/digest-mc-4.5.53-r1 b/gnome-apps/mc/files/digest-mc-4.5.53-r1
new file mode 100644
index 000000000000..e054f7378d97
--- /dev/null
+++ b/gnome-apps/mc/files/digest-mc-4.5.53-r1
@@ -0,0 +1 @@
+MD5 90652e48aaf2e5f937262de8436b7f56 mc-4.5.53.tar.gz
diff --git a/gnome-apps/mc/mc-4.5.53-r1.ebuild b/gnome-apps/mc/mc-4.5.53-r1.ebuild
new file mode 100644
index 000000000000..723e910275f6
--- /dev/null
+++ b/gnome-apps/mc/mc-4.5.53-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-apps/mc/mc-4.5.53-r1.ebuild,v 1.1 2001/05/05 17:42:37 achim Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME Midnight Commander"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/mc/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/gpm-1.19.3
+ pam? ( >=sys-libs/pam-0.72 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ >=sys-apps/e2fsprogs-1.19
+ gnome? ( >=gnome-base/gnome-libs-1.2.4 )
+
+"
+RDEPEND="virtual/x11-web-browser"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/vfs
+ cp smbfs.c smbfs.c.orig
+ sed -e "s:/etc/smb\.conf:/etc/smb/smb\.conf:" smbfs.c.orig > smbfs.c
+}
+
+src_compile() {
+ local myconf
+ if [ "`use pam`" ] ; then
+ myconf="--with-pam"
+ else
+ myconf="--without-pam"
+ fi
+ if [ "`use slang`" ] ; then
+ myconf="$myconf --with-slang"
+ else
+ myconf="$myconf --with-included-slang"
+ fi
+ if [ "`use gnome`" ] ; then
+ myconf="$myconf --with-gnome --prefix=/opt/gnome"
+ else
+ myconf="$myconf --without-gnome --prefix=/usr"
+ fi
+ LDFLAGS="-lcrypt -lncurses" try ./configure --host=${CHOST} \
+ --with-samba --with-vfs --with-netrc $myconf
+ try make
+}
+
+src_install() {
+
+ if [ "`use gnome`" ] ; then
+ try make prefix=${D}/opt/gnome install
+ else
+ try make prefix=${D}/usr install
+ fi
+
+ dodoc ABOUT-NLS COPYING* FAQ INSTALL* NEWS
+ dodoc README*
+}
+
+
+
+
+
+