summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-06-20 10:09:21 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-06-20 10:09:21 +0000
commitbbfef8c2eac10426ec121b4b33290fa213593365 (patch)
treea534f994676290e0a6041e6310268a584d72bfee /gnome-apps/mc
parentcrux informed me that ppp had permanently moved to a new location, changed in... (diff)
downloadhistorical-bbfef8c2eac10426ec121b4b33290fa213593365.tar.gz
historical-bbfef8c2eac10426ec121b4b33290fa213593365.tar.bz2
historical-bbfef8c2eac10426ec121b4b33290fa213593365.zip
included depend on glib, thanks troxx for reporting
Diffstat (limited to 'gnome-apps/mc')
-rw-r--r--gnome-apps/mc/files/digest-mc-4.5.54-r11
-rw-r--r--gnome-apps/mc/mc-4.5.54-r1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/gnome-apps/mc/files/digest-mc-4.5.54-r1 b/gnome-apps/mc/files/digest-mc-4.5.54-r1
new file mode 100644
index 000000000000..c29ea6e31838
--- /dev/null
+++ b/gnome-apps/mc/files/digest-mc-4.5.54-r1
@@ -0,0 +1 @@
+MD5 46bd6d7e25fc3f509c5d8d063fa701eb mc-4.5.54.tar.gz
diff --git a/gnome-apps/mc/mc-4.5.54-r1.ebuild b/gnome-apps/mc/mc-4.5.54-r1.ebuild
new file mode 100644
index 000000000000..3a97ac56b861
--- /dev/null
+++ b/gnome-apps/mc/mc-4.5.54-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-apps/mc/mc-4.5.54-r1.ebuild,v 1.1 2001/06/20 10:09:21 hallski Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME Midnight Commander"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/mc/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/gpm-1.19.3
+ pam? ( >=sys-libs/pam-0.72 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ >=sys-apps/e2fsprogs-1.19
+ >=dev-libs/glib-1.2.0
+ gnome? ( >=gnome-base/gnome-libs-1.2.4 )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/vfs
+ cp smbfs.c smbfs.c.orig
+ sed -e "s:/etc/smb\.conf:/etc/smb/smb\.conf:" smbfs.c.orig > smbfs.c
+}
+
+src_compile() {
+ local myconf
+ if [ "`use pam`" ] ; then
+ myconf="--with-pam"
+ else
+ myconf="--without-pam"
+ fi
+ if [ "`use slang`" ] ; then
+ myconf="$myconf --with-slang"
+ else
+ myconf="$myconf --with-included-slang"
+ fi
+ if [ "`use gnome`" ] ; then
+ myconf="$myconf --with-gnome --prefix=/opt/gnome"
+ else
+ myconf="$myconf --without-gnome --prefix=/usr"
+ fi
+ LDFLAGS="-lcrypt -lncurses" try ./configure --host=${CHOST} \
+ --with-samba --with-vfs --with-netrc $myconf
+ try make # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+
+ if [ "`use gnome`" ] ; then
+ try make prefix=${D}/opt/gnome install
+ else
+ try make prefix=${D}/usr install
+ fi
+
+ dodoc ABOUT-NLS COPYING* FAQ INSTALL* NEWS
+ dodoc README*
+}
+
+
+
+
+
+