summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-05-27 18:43:41 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-05-27 18:43:41 +0000
commit67293dee44d6c035d7e01a7843c5e2c5d6b0c272 (patch)
tree5af7a77829e9eb014aee11e82a31da098e2b30a3 /gnome-base/ORBit/ORBit-0.5.16.ebuild
parentsourceforge updates (diff)
downloadhistorical-67293dee44d6c035d7e01a7843c5e2c5d6b0c272.tar.gz
historical-67293dee44d6c035d7e01a7843c5e2c5d6b0c272.tar.bz2
historical-67293dee44d6c035d7e01a7843c5e2c5d6b0c272.zip
new version
Diffstat (limited to 'gnome-base/ORBit/ORBit-0.5.16.ebuild')
-rw-r--r--gnome-base/ORBit/ORBit-0.5.16.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnome-base/ORBit/ORBit-0.5.16.ebuild b/gnome-base/ORBit/ORBit-0.5.16.ebuild
new file mode 100644
index 000000000000..79d42690b13b
--- /dev/null
+++ b/gnome-base/ORBit/ORBit-0.5.16.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.16.ebuild,v 1.1 2002/05/27 18:43:41 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A high-performance, lightweight CORBA ORB aiming for CORBA 2.2 compliance"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.labs.redhat.com/orbit/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-apps/tcp-wrappers-7.6
+ =dev-libs/glib-1.2*"
+
+RDEPEND="virtual/glibc
+ =dev-libs/glib-1.2*"
+
+
+src_compile() {
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ # Libtoolize to fix "relink bug" in older libtool's distributed
+ # with packages.
+ libtoolize --copy --force
+ cd popt
+ libtoolize --copy --force
+ cd ../libIDL
+ libtoolize --copy --force
+ cd ${S}
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dodoc docs/*.txt docs/IDEA1
+
+ docinto idl
+ cd libIDL
+ dodoc AUTHORS BUGS COPYING NEWS README*
+
+ docinto popt
+ cd ../popt
+ dodoc CHANGES COPYING README
+
+ cd ${D}/usr/lib
+ patch -p0 < ${FILESDIR}/libIDLConf.sh-gentoo.diff
+}
+