summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-04-02 16:33:10 +0000
committerMarinus Schraal <foser@gentoo.org>2004-04-02 16:33:10 +0000
commit191aee11c9c3f4338c6067ce5ba1f8397ef0457d (patch)
treed1f9d437d1bb4780f127d940bb13fcfada6a67f9 /gnome-base/control-center/control-center-2.6.0.3.ebuild
parentadded s390 to keywords (diff)
downloadhistorical-191aee11c9c3f4338c6067ce5ba1f8397ef0457d.tar.gz
historical-191aee11c9c3f4338c6067ce5ba1f8397ef0457d.tar.bz2
historical-191aee11c9c3f4338c6067ce5ba1f8397ef0457d.zip
more 2.6
Diffstat (limited to 'gnome-base/control-center/control-center-2.6.0.3.ebuild')
-rw-r--r--gnome-base/control-center/control-center-2.6.0.3.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/gnome-base/control-center/control-center-2.6.0.3.ebuild b/gnome-base/control-center/control-center-2.6.0.3.ebuild
new file mode 100644
index 000000000000..a9502757c213
--- /dev/null
+++ b/gnome-base/control-center/control-center-2.6.0.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/control-center/control-center-2.6.0.3.ebuild,v 1.1 2004/04/02 16:33:10 foser Exp $
+
+# FIXME : double check all the acme stuff
+inherit gnome2 eutils
+
+DESCRIPTION="The gnome2 Desktop configuration tool"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="GPL-2"
+
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips"
+IUSE="alsa gstreamer"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+RDEPEND=">=x11-libs/gtk+-2.3
+ virtual/xft
+ media-libs/fontconfig
+ >=dev-libs/atk-1.2
+ >=gnome-base/gconf-1.2
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libbonobo-2.2
+ >=gnome-base/libbonoboui-2.2
+ >=gnome-base/nautilus-2.2
+ >=gnome-base/gnome-vfs-2.2
+ >=gnome-base/gnome-desktop-2.2
+ dev-libs/libxml2
+ media-sound/esound
+ >=x11-wm/metacity-2.4.5
+ >=x11-libs/libxklavier-1
+ alsa? ( >=media-libs/alsa-lib-0.9 )
+ gstreamer? ( >=media-libs/gst-plugins-0.8 )
+ !gnome-extra/fontilus
+ !gnome-extra/themus
+ !gnome-extra/acme"
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-0.3.11
+ >=dev-util/pkgconfig-0.12.0
+ >=dev-util/intltool-0.29"
+
+DOCS="AUTHORS ChangeLog COPYING README TODO INSTALL NEWS"
+
+G2CONF="${G2CONF} \
+ --disable-schemas-install\
+ --enable-vfs-methods \
+ $(use_enable alsa) \
+ $(use_enable gstreamer)"
+
+USE_DESTDIR="1"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ # See http://gcc.gnu.org/cgi-bin/gnatsweb.pl problem #9700 for
+ # what this is about.
+ use alpha && epatch ${FILESDIR}/control-center-2.2.0.1-alpha_hack.patch
+
+ # temporary fix for icon installation adapted by <link@sub_pop.net> (#16928)
+ # FIXME : this broke again
+# epatch ${FILESDIR}/${PN}-2.2-icons_install.patch
+
+}