summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-10-24 19:37:52 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-10-24 19:37:52 +0000
commit4539034eebf24af774cf31ee4549d1e48a7c61a7 (patch)
tree0073fc33ba6122058587ddd2c9408b1b94e9c73a /gnome-base/gconf
parentfixed typo. Changed 'econ' to 'econf' (diff)
downloadhistorical-4539034eebf24af774cf31ee4549d1e48a7c61a7.tar.gz
historical-4539034eebf24af774cf31ee4549d1e48a7c61a7.tar.bz2
historical-4539034eebf24af774cf31ee4549d1e48a7c61a7.zip
an update for a build problem (libtool related) that appeared on fresh systems
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog10
-rw-r--r--gnome-base/gconf/files/digest-gconf-1.0.8-r41
-rw-r--r--gnome-base/gconf/gconf-1.0.8-r4.ebuild72
3 files changed, 82 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 98465ad9ce02..32da74a9ac6a 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.21 2002/08/06 04:42:12 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.22 2002/10/24 19:37:51 spider Exp $
+
+*gconf-1.0.8-r4 (24 Oct 2002)
+ 24 Oct 2002; Spider <spider@gentoo.org> gconf-1.0.8-r4.ebuild : I made some
+ Changes to the ebuild, libtool and others. the previous version broke during
+ galeon install on some clean 1.4 systems, where this version works. test on
+ other systems but it should be ok.
+
+
*gconf-1.2.0-r5 (05 Aug 2002)
05 Aug 2002; Leonardo Boshell <leonardop@gentoo.org> gconf-1.2.0-r5.ebuild:
Fix sandbox violations affecting the installation under certain
diff --git a/gnome-base/gconf/files/digest-gconf-1.0.8-r4 b/gnome-base/gconf/files/digest-gconf-1.0.8-r4
new file mode 100644
index 000000000000..94b9f10e773b
--- /dev/null
+++ b/gnome-base/gconf/files/digest-gconf-1.0.8-r4
@@ -0,0 +1 @@
+MD5 b0d662f3fa1dbab01796efe695577c74 GConf-1.0.8.tar.gz 1240140
diff --git a/gnome-base/gconf/gconf-1.0.8-r4.ebuild b/gnome-base/gconf/gconf-1.0.8-r4.ebuild
new file mode 100644
index 000000000000..6c85e7207360
--- /dev/null
+++ b/gnome-base/gconf/gconf-1.0.8-r4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.8-r4.ebuild,v 1.1 2002/10/24 19:37:52 spider Exp $
+
+IUSE="nls"
+
+S=${WORKDIR}/GConf-${PV}
+DESCRIPTION="Gconf"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/GConf/GConf-${PV}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+inherit libtool
+
+
+RDEPEND=">=sys-libs/db-3.2.3h
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/guile-1.4
+ dev-util/indent
+ =dev-libs/glib-1.2*
+ dev-libs/libxml
+ dev-libs/popt
+ gnome-base/oaf
+ gnome-base/ORBit"
+
+src_compile() {
+ local myconf
+
+ elibtoolize
+
+ use nls \
+ || myconf="--disable-nls" \
+ && mkdir intl \
+ && touch intl/libgettext.h
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+ # gconf 1.0.8 seems to gets the perms wrong on this dir.
+ chmod 0755 ${D}/etc/gconf/gconf.xml.mandatory
+ # this fix closes bug #803
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}
+
+pkg_postinst() {
+ # this is to fix installations where the following dir
+ # has already been merged with incorrect permissions.
+ # We can remove this fix after gconf 1.0.8 is an ancient
+ # version.
+ if [ ! -e ${ROOT}/etc/gconf/gconf.xml.mandatory ]
+ then
+ #unmerge of older revisions nuke this one
+ mkdir -p ${ROOT}/etc/gconf/gconf.xml.mandatory
+ fi
+ chmod 0755 ${ROOT}/etc/gconf/gconf.xml.mandatory
+}