summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-04-15 18:57:14 +0000
committerPeter Gavin <pete@gentoo.org>2001-04-15 18:57:14 +0000
commitbced03b38143fd04293401fbf60686ac3924c07e (patch)
tree93f7c6d811104b7ff53265a4d542504595fc5ed3 /gnome-base/gnome-core/files
parent*** empty log message *** (diff)
downloadhistorical-bced03b38143fd04293401fbf60686ac3924c07e.tar.gz
historical-bced03b38143fd04293401fbf60686ac3924c07e.tar.bz2
historical-bced03b38143fd04293401fbf60686ac3924c07e.zip
more gnome updates
Diffstat (limited to 'gnome-base/gnome-core/files')
-rw-r--r--gnome-base/gnome-core/files/digest-gnome-core-1.4.0.11
-rw-r--r--gnome-base/gnome-core/files/gnome-core-1.4.0.1-gentoo.diff65
2 files changed, 66 insertions, 0 deletions
diff --git a/gnome-base/gnome-core/files/digest-gnome-core-1.4.0.1 b/gnome-base/gnome-core/files/digest-gnome-core-1.4.0.1
new file mode 100644
index 000000000000..4517927100f0
--- /dev/null
+++ b/gnome-base/gnome-core/files/digest-gnome-core-1.4.0.1
@@ -0,0 +1 @@
+MD5 b1a0b8485b3347e5e033f414ca7eefd1 gnome-core-1.4.0.1.tar.gz
diff --git a/gnome-base/gnome-core/files/gnome-core-1.4.0.1-gentoo.diff b/gnome-base/gnome-core/files/gnome-core-1.4.0.1-gentoo.diff
new file mode 100644
index 000000000000..edabb9d210e5
--- /dev/null
+++ b/gnome-base/gnome-core/files/gnome-core-1.4.0.1-gentoo.diff
@@ -0,0 +1,65 @@
+diff -urP gnome-core-1.4.0.1.orig/configure.in gnome-core-1.4.0.1/configure.in
+--- gnome-core-1.4.0.1.orig/configure.in Wed Mar 28 11:49:10 2001
++++ gnome-core-1.4.0.1/configure.in Sun Apr 15 14:04:14 2001
+@@ -283,6 +283,15 @@
+ ])
+ ])
+
++CPPFLAGS=`$GNOME_CONFIG --cflags print`
++LDFLAGS=`$GNOME_CONFIG --libs print`
++
++lib_gnomeprint=false
++AC_CHECK_LIB(gnomeprint, main, lib_gnomeprint=true, [
++ AC_MSG_WARN([GnomePrint not found (using GtkXmHTML)
++ ])
++])
++
+ CPPFLAGS=$CPPFLAGS_save
+ LDFLAGS=$LDFLAGS_save
+
+@@ -291,22 +300,18 @@
+ gtkhtml_enabled="$enableval", gtkhtml_enabled=no)
+
+ if test "x$gtkhtml_enabled" = "xyes" ; then
+- if test "x$lib_gtkhtml" = "xtrue" ; then
+- AC_MSG_CHECKING(for static libgtkhtml)
+- if test -e $GTK_HTML_PREFIX/lib/libgtkhtml.a ; then
+- AC_MSG_RESULT(yes)
+- AC_MSG_CHECKING(for static libgnomeprint)
+- if test -e $GNOME_PRINT_PREFIX/lib/libgnomeprint.a ; then
+- AC_MSG_RESULT(yes)
+- help_use_gtkhtml=true
+- else
+- AC_MSG_RESULT(no)
+- fi
+- else
+- AC_MSG_RESULT(no)
+- fi
++ if test \( "x$lib_gtkhtml" = "xtrue" \) -a \( "x$lib_gnomeprint" = "xtrue" \) ; then
++ GTKHTML_CFLAGS=`$GNOME_CONFIG --cflags gtkhtml`
++ GTKHTML_LIBS=`$GNOME_CONFIG --libs gtkhtml`
++ GNOMEPRINT_CFLAGS=`$GNOME_CONFIG --cflags print`
++ GNOMEPRINT_LIBS=`$GNOME_CONFIG --libs print`
++ help_use_gtkhtml=true
+ fi
+ fi
++AC_SUBST(GTKHTML_CFLAGS)
++AC_SUBST(GTKHTML_LIBS)
++AC_SUBST(GNOMEPRINT_CFLAGS)
++AC_SUBST(GNOMEPRINT_LIBS)
+
+ AC_MSG_CHECKING(which HTML widget to use)
+ if test "x$help_use_gtkhtml" = "xtrue" ; then
+diff -urP gnome-core-1.4.0.1.orig/help-browser/Makefile.am gnome-core-1.4.0.1/help-browser/Makefile.am
+--- gnome-core-1.4.0.1.orig/help-browser/Makefile.am Mon Feb 5 11:04:57 2001
++++ gnome-core-1.4.0.1/help-browser/Makefile.am Sun Apr 15 12:50:28 2001
+@@ -16,8 +16,7 @@
+
+ if HELP_USE_GTKHTML
+ htmllibs = $(GNOME_XML_LIB) @PIXBUF_LIBS@ \
+- $(GTK_HTML_PREFIX)/lib/libgtkhtml.a \
+- $(GNOME_PRINT_PREFIX)/lib/libgnomeprint.a
++ $(GTKHTML_LIBS) $(GNOMEPRINT_LIBS)
+ else
+ htmllibs = $(GTKXMHTML_LIBS)
+ endif