summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-07 07:50:00 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-07 07:50:00 +0000
commit901efd168a526079d5a7a7ba3d5573323bfbb524 (patch)
tree32cc4f5efdf3fbfc73e0878bee86c2b93b4dd513 /gnome-base/gnome-light
parentAdd the sub-meta package for gnome-3 fallback mode from the gnome overlay. (diff)
downloadhistorical-901efd168a526079d5a7a7ba3d5573323bfbb524.tar.gz
historical-901efd168a526079d5a7a7ba3d5573323bfbb524.tar.bz2
historical-901efd168a526079d5a7a7ba3d5573323bfbb524.zip
Bump to 3.2.1 from the gnome overlay. Uses the new sub-meta packages. Dropped alpha, arm, ia64, ppc, ppc64, sparc, x86-freebsd, amd64-linux, x86-linux, x86-solaris keywords due to new dependencies. Keywording bug will be filed soon.
Package-Manager: portage-2.2.0_alpha72/cvs/Linux x86_64
Diffstat (limited to 'gnome-base/gnome-light')
-rw-r--r--gnome-base/gnome-light/ChangeLog11
-rw-r--r--gnome-base/gnome-light/gnome-light-3.2.1.ebuild55
-rw-r--r--gnome-base/gnome-light/metadata.xml4
3 files changed, 69 insertions, 1 deletions
diff --git a/gnome-base/gnome-light/ChangeLog b/gnome-base/gnome-light/ChangeLog
index e235920edd3e..4c8eaebf9ae8 100644
--- a/gnome-base/gnome-light/ChangeLog
+++ b/gnome-base/gnome-light/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-base/gnome-light
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-light/ChangeLog,v 1.148 2011/10/28 20:04:07 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-light/ChangeLog,v 1.149 2011/11/07 07:50:00 tetromino Exp $
+
+*gnome-light-3.2.1 (07 Nov 2011)
+
+ 07 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +gnome-light-3.2.1.ebuild, metadata.xml:
+ Bump to 3.2.1 from the gnome overlay. Uses the new sub-meta packages. Dropped
+ alpha, arm, ia64, ppc, ppc64, sparc, x86-freebsd, amd64-linux, x86-linux,
+ x86-solaris keywords due to new dependencies. Keywording bug will be filed
+ soon.
28 Oct 2011; Markus Meier <maekke@gentoo.org> gnome-light-2.32.1-r1.ebuild:
arm stable, bug #385699
diff --git a/gnome-base/gnome-light/gnome-light-3.2.1.ebuild b/gnome-base/gnome-light/gnome-light-3.2.1.ebuild
new file mode 100644
index 000000000000..cfbcce2e1e31
--- /dev/null
+++ b/gnome-base/gnome-light/gnome-light-3.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-light/gnome-light-3.2.1.ebuild,v 1.1 2011/11/07 07:50:00 tetromino Exp $
+
+EAPI="4"
+
+DESCRIPTION="Meta package for GNOME-Light, merge this package to install"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="as-is"
+SLOT="2.0"
+IUSE="cups +fallback +gnome-shell"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~amd64 ~x86"
+
+# XXX: Note to developers:
+# This is a wrapper for the 'light' GNOME 3 desktop, and should only consist of
+# the bare minimum of libs/apps needed. It is basically gnome-base/gnome without
+# any apps, but shouldn't be used by users unless they know what they are doing.
+RDEPEND="!gnome-base/gnome
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+
+ >=gnome-base/gnome-session-${PV}
+ >=gnome-base/gnome-menus-3.2:3
+ >=gnome-base/gnome-settings-daemon-${PV}[cups?]
+ >=gnome-base/gnome-control-center-${PV}[cups?]
+
+ >=gnome-base/nautilus-${PV}
+
+ gnome-shell? (
+ >=x11-wm/mutter-${PV}
+ >=gnome-base/gnome-shell-${PV} )
+
+ fallback? ( >=gnome-base/gnome-fallback-${PV} )
+
+ >=x11-themes/gnome-icon-theme-${PV}
+ >=x11-themes/gnome-icon-theme-symbolic-${PV}
+ >=x11-themes/gnome-themes-standard-${PV}
+
+ >=x11-terms/gnome-terminal-${PV}
+"
+DEPEND=""
+PDEPEND=">=gnome-base/gvfs-1.10.1"
+S=${WORKDIR}
+
+pkg_pretend() {
+ if ! use fallback && ! use shell; then
+ # Users probably want to use e16, sawfish, etc
+ ewarn "You're installing neither GNOME Shell nor GNOME Fallback!"
+ ewarn "You will have to install and manage a window manager by yourself"
+ # https://bugs.gentoo.org/show_bug.cgi?id=303375
+ ewarn "See: <add link to docs about component handling in gnome-session>"
+ fi
+}
diff --git a/gnome-base/gnome-light/metadata.xml b/gnome-base/gnome-light/metadata.xml
index b1870850816a..82398e195cea 100644
--- a/gnome-base/gnome-light/metadata.xml
+++ b/gnome-base/gnome-light/metadata.xml
@@ -5,5 +5,9 @@
<use>
<flag name="automount">Use <pkg>gnome-base/gvfs[gdu]</pkg> for automounting
of drives in nautilus</flag>
+ <flag name="fallback">Install <pkg>gnome-base/gnome-panel</pkg> and
+ <pkg>x11-wm/metacity</pkg> for the GNOME 3 fallback mode</flag>
+ <flag name="gnome-shell">Install <pkg>gnome-base/gnome-shell</pkg> and
+ <pkg>x11-wm/mutter</pkg> for the standard GNOME 3 desktop mode</flag>
</use>
</pkgmetadata>