summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-04-15 18:57:14 +0000
committerPeter Gavin <pete@gentoo.org>2001-04-15 18:57:14 +0000
commitbced03b38143fd04293401fbf60686ac3924c07e (patch)
tree93f7c6d811104b7ff53265a4d542504595fc5ed3 /gnome-base/libglade
parent*** empty log message *** (diff)
downloadhistorical-bced03b38143fd04293401fbf60686ac3924c07e.tar.gz
historical-bced03b38143fd04293401fbf60686ac3924c07e.tar.bz2
historical-bced03b38143fd04293401fbf60686ac3924c07e.zip
more gnome updates
Diffstat (limited to 'gnome-base/libglade')
-rw-r--r--gnome-base/libglade/files/digest-libglade-0.16-r11
-rw-r--r--gnome-base/libglade/libglade-0.16-r1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-base/libglade/files/digest-libglade-0.16-r1 b/gnome-base/libglade/files/digest-libglade-0.16-r1
new file mode 100644
index 000000000000..58af1e0503a9
--- /dev/null
+++ b/gnome-base/libglade/files/digest-libglade-0.16-r1
@@ -0,0 +1 @@
+MD5 6b98bbf13ee08e571d96765662dfd344 libglade-0.16.tar.gz
diff --git a/gnome-base/libglade/libglade-0.16-r1.ebuild b/gnome-base/libglade/libglade-0.16-r1.ebuild
new file mode 100644
index 000000000000..7bde14730312
--- /dev/null
+++ b/gnome-base/libglade/libglade-0.16-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-0.16-r1.ebuild,v 1.1 2001/04/15 18:57:14 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libglade"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
+ ftp://gnome.eazel.com/pub/gnome/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=gnome-base/gnome-libs-1.2.12
+ >=gnome-base/libxml-1.8.11
+ bonobo? ( >=gnome-base/bonobo-0.37 )"
+
+src_compile() {
+
+ local myopts
+ if [ "`use bonobo`" ]
+ then
+ # I had to add --disable-bonobotest, because, for some reason,
+ # the conftest in configure segfaults, but libglade still
+ # compiles and runs just fine... -- pete
+ myconf="--enable-bonobo --disable-bonobotest"
+ else
+ myconf="--disable-bonobo"
+ fi
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome ${myconf}
+ try make
+
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING* ChangeLog NEWS
+ dodoc doc/*.txt
+}
+
+
+
+
+
+
+
+
+