summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-08-16 20:33:40 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-08-16 20:33:40 +0000
commit26af1f49a1bfb8a0135570f7d0750244c0b0188e (patch)
tree1a9c35aa61678210e2166336c8733189fe53211a /gnome-base/orbit/orbit-2.12.3.ebuild
parentGet rid of references to /usr/X11R6. (diff)
downloadhistorical-26af1f49a1bfb8a0135570f7d0750244c0b0188e.tar.gz
historical-26af1f49a1bfb8a0135570f7d0750244c0b0188e.tar.bz2
historical-26af1f49a1bfb8a0135570f7d0750244c0b0188e.zip
New version: 2.12.3. Removing old ebuilds.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'gnome-base/orbit/orbit-2.12.3.ebuild')
-rw-r--r--gnome-base/orbit/orbit-2.12.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnome-base/orbit/orbit-2.12.3.ebuild b/gnome-base/orbit/orbit-2.12.3.ebuild
new file mode 100644
index 000000000000..a15c8ed088ef
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.12.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.12.3.ebuild,v 1.1 2005/08/16 20:33:40 leonardop Exp $
+
+inherit gnome2
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc ssl static"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/popt-1.5
+ >=dev-libs/libIDL-0.8.2
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+# FIXME linc is now integrated, but a block isn't necessary
+# and probably complicated FIXME
+
+# FIXME ssl is optional, but not switchable
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.14
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+USE_DESTDIR="1"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+
+pkg_setup() {
+ G2CONF="$(use_enable static)"
+}