summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-08 00:59:36 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-08 00:59:36 +0000
commita36cae71a69dee12fe1de0f7ac35a69e31795bd0 (patch)
tree2ffcd0b89f42295749215f766c4923d837bdac08 /gnome-base/orbit/orbit-2.14.17.ebuild
parentInitial commit of twisted-web2 to reflect all upstream twisted modules (diff)
downloadhistorical-a36cae71a69dee12fe1de0f7ac35a69e31795bd0.tar.gz
historical-a36cae71a69dee12fe1de0f7ac35a69e31795bd0.tar.bz2
historical-a36cae71a69dee12fe1de0f7ac35a69e31795bd0.zip
Bump to 2.14.17. Build fixes and enhancements to linc. Clean up old revisions.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'gnome-base/orbit/orbit-2.14.17.ebuild')
-rw-r--r--gnome-base/orbit/orbit-2.14.17.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-base/orbit/orbit-2.14.17.ebuild b/gnome-base/orbit/orbit-2.14.17.ebuild
new file mode 100644
index 000000000000..c6a32325d7b4
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.17.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.17.ebuild,v 1.1 2009/03/08 00:59:36 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=dev-libs/libIDL-0.8.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}
+
+src_test() {
+ # can fail in parallel, see bug #235994
+ emake -j1 check || die "tests failed"
+}