summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-29 01:21:17 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-29 01:21:17 +0000
commitc43550e33ee8d5c1f60f010f493dd4c83df66c5a (patch)
treeb973096739dc136e38f08b856ff5dd3e0e4d1cd1 /gnome-extra/gnome-games
parentfix oops (diff)
downloadhistorical-c43550e33ee8d5c1f60f010f493dd4c83df66c5a.tar.gz
historical-c43550e33ee8d5c1f60f010f493dd4c83df66c5a.tar.bz2
historical-c43550e33ee8d5c1f60f010f493dd4c83df66c5a.zip
new version
Diffstat (limited to 'gnome-extra/gnome-games')
-rw-r--r--gnome-extra/gnome-games/ChangeLog6
-rw-r--r--gnome-extra/gnome-games/files/digest-gnome-games-1.93.01
-rw-r--r--gnome-extra/gnome-games/gnome-games-1.93.0.ebuild157
3 files changed, 163 insertions, 1 deletions
diff --git a/gnome-extra/gnome-games/ChangeLog b/gnome-extra/gnome-games/ChangeLog
index d5e9e73f6dcc..7f9de0cacceb 100644
--- a/gnome-extra/gnome-games/ChangeLog
+++ b/gnome-extra/gnome-games/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/gnome-games
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.4 2002/05/22 22:18:39 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.5 2002/05/29 01:21:17 spider Exp $
+
+*gnome-games-1.93.0 (28 May 2002)
+ 28 May 2002; Spider <spider@gentoo.org> gnome-games-1.932.0.ebuild:
+ new version
*gnome-games-1.92.0 (22 May 2002)
22 May 2002; Spider <spider@gentoo.org> gnome-games-1.92.0.ebuild:
diff --git a/gnome-extra/gnome-games/files/digest-gnome-games-1.93.0 b/gnome-extra/gnome-games/files/digest-gnome-games-1.93.0
new file mode 100644
index 000000000000..48e566151336
--- /dev/null
+++ b/gnome-extra/gnome-games/files/digest-gnome-games-1.93.0
@@ -0,0 +1 @@
+MD5 938638e4a31bb8041b7f0d7996c6204c gnome-games-1.93.0.tar.bz2 8884463
diff --git a/gnome-extra/gnome-games/gnome-games-1.93.0.ebuild b/gnome-extra/gnome-games/gnome-games-1.93.0.ebuild
new file mode 100644
index 000000000000..8b0008ec03c2
--- /dev/null
+++ b/gnome-extra/gnome-games/gnome-games-1.93.0.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-1.93.0.ebuild,v 1.1 2002/05/29 01:21:17 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Games for the Gnome2 desktop"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ >=x11-libs/pango-1.0.2
+ >=dev-libs/atk-1.0.2
+ >=x11-libs/gtk+-2.0.3
+ >=x11-libs/libzvt-1.116.0
+ =media-libs/freetype-2.0*
+ >=dev-libs/libxml2-2.4.22
+ >=app-text/scrollkeeper-0.3.4-r1
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1
+ >=sys-devel/gettext-0.10.40
+ >=dev-util/guile-1.5.4
+ >=gnome-base/libglade-1.99.8-r1
+ >=gnome-base/gconf-1.1.8-r1
+ >=gnome-base/libgnomeui-1.117.1
+ >=gnome-base/libgnome-1.117.1
+ >=gnome-base/gnome-vfs-1.9.10
+ >=gnome-base/ORBit2-2.4.0
+ >=gnome-base/bonobo-activation-0.9.9
+ >=gnome-base/gnome-panel-1.5.23
+ >=gnome-base/libgnomecanvas-1.117.0"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=dev-util/intltool-0.17
+ ${RDEPEND}"
+
+
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/lib \
+ --disable-guname-capplet \
+ --enable-gcolorsel-applet \
+ --with-ncurses \
+ --enable-debug=yes || die "configure failure"
+ emake || die "compile failure"
+}
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ localstatedir=${D}/var/lib \
+ install || die "install failure"
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+
+ dodoc AUTHORS COPYING COPYING-DOCS ChangeLog HACKING INSTALL MAINTAINERS NEWS README TODO
+
+ docinto aisleriot
+ cd aisleriot
+ dodoc AUTHORS ChangeLog TODO
+
+ cd ../freecell
+ docinto freecell
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ cd ../gataxx
+ docinto gataxx
+ dodoc AUTHORS ChangeLog TODO
+
+ cd ../glines
+ docinto glines
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ cd ../gnect
+ docinto gnect
+ dodoc AUTHORS ChangeLog TODO
+
+ cd ../gnibbles
+ docinto gnibbles
+ dodoc AUTHORS ChangeLog
+
+ cd ../gnobots2
+ docinto gnobots2
+ dodoc AUTHORS README
+
+ cd ../gnome-stones
+ docinto gnome-stones
+ dodoc ChangeLog README TODO
+
+ cd ../gnometris
+ docinto gnometris
+ dodoc AUTHORS COPYING ChangeLog TODO
+
+ cd ../gnomine
+ docinto gnomine
+ dodoc AUTHORS ChangeLog README
+
+ cd ../gnotravex
+ docinto gnotravex
+ dodoc AUTHORS ChangeLog README
+
+ cd ../gnotski
+ docinto gnotski
+ dodoc AUTHORS ChangeLog README
+
+ cd ../gtali
+ docinto gtali
+ dodoc AUTHORS ChangeLog INSTALL README TODO
+
+ cd ../iagno
+ docinto iagno
+ dodoc AUTHORS ChangeLog
+
+ cd ../mahjongg
+ docinto mahjongg
+ dodoc ChangeLog NEWS README TODO
+
+ cd ../same-gnome
+ docinto same-gnome
+ dodoc ChangeLog README TODO
+
+ cd ../xbill
+ docinto xbill
+ dodoc AUTHORS COPYING ChangeLog NEWS README README.Ports
+
+ cd ..
+}
+
+pkg_postinst() {
+ echo ">>> Scrollkeeper-update"
+ scrollkeeper-update -p /var/lib/scrollkeeper
+ echo ">>> updating GConf2"
+ export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
+ for SCHEMA in freecell.schemas gnect.schemas \
+ gnomine.schemas iagno.schemas gataxx.schemas \
+ gnometris.schemas gtali.schemas same-gnome.schemas ; do
+ echo $SCHEMA
+ /usr/bin/gconftool-2 --makefile-install-rule \
+ /etc/gconf/schemas/${SCHEMA}
+ done
+}
+
+