summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-03-20 07:51:20 +0000
committerMarinus Schraal <foser@gentoo.org>2004-03-20 07:51:20 +0000
commit16edfa93d8101b422f9db038c745a408e1027e52 (patch)
treeb0b8cafde8e4326de1d4673208a21e3251e6f876 /gnome-extra/gtkhtml
parentheader fix (diff)
downloadhistorical-16edfa93d8101b422f9db038c745a408e1027e52.tar.gz
historical-16edfa93d8101b422f9db038c745a408e1027e52.tar.bz2
historical-16edfa93d8101b422f9db038c745a408e1027e52.zip
remove old insecure version
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/Manifest2
-rw-r--r--gnome-extra/gtkhtml/files/digest-gtkhtml-1.1.81
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-1.1.8.ebuild141
3 files changed, 0 insertions, 144 deletions
diff --git a/gnome-extra/gtkhtml/Manifest b/gnome-extra/gtkhtml/Manifest
index 86d390e2a2eb..99c4f9d9d586 100644
--- a/gnome-extra/gtkhtml/Manifest
+++ b/gnome-extra/gtkhtml/Manifest
@@ -1,8 +1,6 @@
MD5 0fd1845c8847e93381162b6be3e97a7f gtkhtml-1.1.10.ebuild 4119
MD5 39acfcd8af20dcf759cc4b432bc1810a gtkhtml-1.1.10-r1.ebuild 4106
-MD5 4e25477f21889dec4fdc7363557e1e71 gtkhtml-1.1.8.ebuild 4054
MD5 35b2f480d4861b75416623beff2dc608 ChangeLog 5674
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
-MD5 e535d0844b7715ab85f1672f4882f7a8 files/digest-gtkhtml-1.1.8 67
MD5 beee6dc1f9b01326aec9a28c8959c395 files/digest-gtkhtml-1.1.10-r1 68
MD5 2da7540b316c5dfdd790869fdb2f4070 files/digest-gtkhtml-1.1.10 133
diff --git a/gnome-extra/gtkhtml/files/digest-gtkhtml-1.1.8 b/gnome-extra/gtkhtml/files/digest-gtkhtml-1.1.8
deleted file mode 100644
index 79b228234901..000000000000
--- a/gnome-extra/gtkhtml/files/digest-gtkhtml-1.1.8
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ea64ac887b834573d4ee6279926ba245 gtkhtml-1.1.8.tar.bz2 1079444
diff --git a/gnome-extra/gtkhtml/gtkhtml-1.1.8.ebuild b/gnome-extra/gtkhtml/gtkhtml-1.1.8.ebuild
deleted file mode 100644
index 351d2776e0a0..000000000000
--- a/gnome-extra/gtkhtml/gtkhtml-1.1.8.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-1.1.8.ebuild,v 1.9 2003/09/28 08:31:52 liquidx Exp $
-
-IUSE="nls gnome"
-
-inherit gnome.org libtool
-
-MY_PV="`echo ${PV} | cut -d. -f1,2`"
-S="${WORKDIR}/${P}"
-DESCRIPTION="Lightweight HTML rendering/printing/editing engine."
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="GPL-2 LGPL-2.1"
-# This one lets gtkhtml-1.0 compiled stuff work, but some stuff do
-# not compile, so not sure as to what to set SLOT to .. it could be
-# that new versions will support 1.[12] of gtkhtml ...
-SLOT="0"
-KEYWORDS="x86 ~ppc sparc ~alpha"
-
-# peg gtkhtml at gal-0.23 because it might get confused with gal-1.99
-RDEPEND="<gnome-extra/gal-1.99
- <gnome-base/control-center-1.99.0
- >=gnome-base/libghttp-1.0.9-r1
- >=dev-libs/libunicode-0.4-r1
- >=gnome-base/gnome-print-0.34
- >=gnome-base/bonobo-1.0.20
- nls? ( sys-devel/gettext
- >=dev-util/intltool-0.11 )
- <gnome-base/libglade-0.99.0
- <gnome-base/gconf-1.1.0"
-# gnome? ( <gnome-base/gconf-1.1.0 )
-# Borks without gconf in most cases
-
-DEPEND="${RDEPEND}"
-
-src_compile() {
- elibtoolize
-
- local myconf=""
- use nls || myconf="${myconf} --disable-nls"
-
- # Evo users need to have bonobo support
- #use bonobo \
- # && myconf="${myconf} --with-bonobo" \
- # || myconf="${myconf} --without-bonobo"
-
- # Otherwise it will use the wrong include dir
- #use gnome \
- # && myconf="${myconf} --with-gconf" \
- # || myconf="${myconf} --without-gconf"
- myconf="${myconf} --with-gconf"
-# Borks without gconf in most cases
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- ${myconf} || die
-
- emake || die "Package building failed."
-}
-
-# This function converts a pkgconfig config type file to
-# a Conf.sh type file used by gnome-config.
-#
-# Usage: conv_pkgconfig_confsh foo.pc
-#
-# <azarah@gentoo.org> (9 Nov 2002)
-conv_pkgconfig_confsh() {
-
- local pkgconfig_file="$1"
- local confsh_file="${pkgconfig_file%%-*}Conf.sh"
- local package_name="`echo ${pkgconfig_file%%-*} | awk '{print toupper($0)}'`"
- local tmpfile="${T}/$$.env"
-
- [ "$#" -ne 1 ] && return 1
- [ ! -f ${D}/usr/lib/pkgconfig/${pkgconfig_file} ] && return 1
-
- # Remove bogus info and convert to bash type file we can
- # source ...
- sed -e 's|: *|=|g' \
- -e '/^$/ d' \
- -e 's|$|"|g' \
- -e 's|=|="|g' \
- -e 's|Libs=|libs=|' \
- -e 's|Cflags=|cflags=|' \
- -e '/^Name.*/ d' \
- -e '/^Description.*/ d' \
- -e '/^Version.*/ d' \
- ${D}/usr/lib/pkgconfig/${pkgconfig_file} > ${tmpfile}
-
- source ${tmpfile}
-
- # Ok, generate our Conf.sh file
- cat > ${D}/usr/lib/${confsh_file} <<CONFSHEND
-#
-# Configuration file for using the ${package_name} library in GNOME applications
-#
-${package_name}_LIBDIR="-L${libdir}"
-${package_name}_LIBS="${libs}"
-${package_name}_INCLUDEDIR="${cflags}"
-${package_name}_DATADIR="${gtkhtml_datadir}"
-MODULE_VERSION="${module_version}"
-
-CONFSHEND
-
- # Fix permissions
- fperms 0755 /usr/lib/${confsh_file}
-}
-
-src_install() {
- local fullname=""
-
- einstall || die
-
- # Fix the double entry in Control Center
- rm -f ${D}/usr/share/control-center/capplets/gtkhtml-properties.desktop
-
- # This next big gets gtkhtml-1.1 to be compadible with gtkhtml-1.0.
- # We basically generate a /usr/lib/gtkhtmlConf.sh so that gnome-config
- # will see gtkhtml-1.1 and other older gnome apps should then be able
- # to use it. We also create libgtkhtml.so and libgtkhtml.so.20 symlinks,
- # and /usr/share/gtkhtml-1.1/gtkhtml symlinks for apps compiled against
- # older gtkhtml to find their libs, and data .idl files.
- #
- # <azarah@gentoo.org> (9 Nov 2002)
- conv_pkgconfig_confsh ${PN}-${MY_PV}.pc
-
- # Add some type of backward compat for libs...
- fullname="`eval basename \`readlink ${D}/usr/lib/lib${PN}-${MY_PV}.so\``"
- dosym ${fullname##*/} /usr/lib/lib${PN}.so
- dosym ${fullname##*/} /usr/lib/lib${PN}.so.20
-
- # For older apps to be able to find the data...
- dosym '.' /usr/share/${PN}-${MY_PV}/${PN}
-
- dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
-}
-