summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-09-14 01:12:24 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-09-14 01:12:24 +0000
commit45e75e4db4922843ff7888b3a4dfb3b0757a4fac (patch)
tree721760decf0981ac39669e7e7f1dc73704026549 /gnome-extra/guppi
parentfixums (diff)
downloadhistorical-45e75e4db4922843ff7888b3a4dfb3b0757a4fac.tar.gz
historical-45e75e4db4922843ff7888b3a4dfb3b0757a4fac.tar.bz2
historical-45e75e4db4922843ff7888b3a4dfb3b0757a4fac.zip
fixed buildproblems with latest Gnumeric (--disable-gnumeric)
Diffstat (limited to 'gnome-extra/guppi')
-rw-r--r--gnome-extra/guppi/files/digest-guppi-0.35.5-r11
-rw-r--r--gnome-extra/guppi/guppi-0.35.5-r1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/gnome-extra/guppi/files/digest-guppi-0.35.5-r1 b/gnome-extra/guppi/files/digest-guppi-0.35.5-r1
new file mode 100644
index 000000000000..8006822e0ff9
--- /dev/null
+++ b/gnome-extra/guppi/files/digest-guppi-0.35.5-r1
@@ -0,0 +1 @@
+MD5 93ba14b9334e3838466446614149e2b4 Guppi-0.35.5.tar.gz
diff --git a/gnome-extra/guppi/guppi-0.35.5-r1.ebuild b/gnome-extra/guppi/guppi-0.35.5-r1.ebuild
new file mode 100644
index 000000000000..f29d6a03e407
--- /dev/null
+++ b/gnome-extra/guppi/guppi-0.35.5-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.64-r1.ebuild,v 1.1 2001/05/17 13:29:30 achim Exp
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/guppi/guppi-0.35.5-r1.ebuild,v 1.1 2001/09/14 01:12:24 hallski Exp $
+
+
+A=Guppi-${PV}.tar.gz
+S=${WORKDIR}/Guppi-${PV}
+DESCRIPTION="GNOME Plottin Tool"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/Guppi/${A}"
+HOMEPAGE="http://www.gnome.org/guppi/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ >=dev-util/guile-1.4
+ >=gnome-office/gnumeric-0.65
+ >=dev-util/xml-i18n-tools-0.8.4
+ python? ( >=dev-lang/python-2.0 )
+ bonobo? ( >=gnome-base/bonobo-0.37 )"
+
+RDEPEND=">=media-libs/gdk-pixbuf-0.11.0
+ >=dev-util/guile-1.4
+ >=gnome-base/gnome-print-0.29
+ bonobo? ( >=gnome-base/bonobo-0.37 )"
+
+src_compile() {
+ local myconf
+
+ if [ "`use bonobo`" ]
+ then
+ myconf="--enable-bonobo"
+ else
+ myconf="--disable-bonobo"
+ fi
+
+ if [ "`use python`" ]
+ then
+ myconf="--enable-python"
+ else
+ myconf="--disable-python"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ if [ -z "`use readline`" ] ; then
+ myconf="$myconf --disable-guile-readline"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --disable-gnumeric \
+ ${myconf}
+
+ try make # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
+
+
+
+
+