summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2005-03-02 05:25:37 +0000
committerMike Gardiner <obz@gentoo.org>2005-03-02 05:25:37 +0000
commit5f8acee2d9ad67093306b244da77dea4906f75e8 (patch)
tree183017288675a53da663f378e15fe276838bfd70 /gnome-extra/libgtkhtml/libgtkhtml-3.2.5.ebuild
parentAdded gcc-config-1.4.0 (diff)
downloadhistorical-5f8acee2d9ad67093306b244da77dea4906f75e8.tar.gz
historical-5f8acee2d9ad67093306b244da77dea4906f75e8.tar.bz2
historical-5f8acee2d9ad67093306b244da77dea4906f75e8.zip
New version
Diffstat (limited to 'gnome-extra/libgtkhtml/libgtkhtml-3.2.5.ebuild')
-rw-r--r--gnome-extra/libgtkhtml/libgtkhtml-3.2.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/libgtkhtml/libgtkhtml-3.2.5.ebuild b/gnome-extra/libgtkhtml/libgtkhtml-3.2.5.ebuild
new file mode 100644
index 000000000000..b3169c1eeda3
--- /dev/null
+++ b/gnome-extra/libgtkhtml/libgtkhtml-3.2.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/libgtkhtml-3.2.5.ebuild,v 1.1 2005/03/02 05:25:37 obz Exp $
+
+inherit gnome2 versionator
+
+MY_P=${P/lib/}
+MY_PN=${PN/lib/}
+MY_MAJ_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Lightweight HTML Rendering/Printing/Editing Engine"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${MY_MAJ_PV}/${MY_P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="3.2"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa ~alpha ~ia64 ~amd64 ~mips ~arm"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND=">=net-libs/libsoup-2.2.1
+ >=x11-libs/gtk+-2.2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=x11-themes/gnome-icon-theme-1.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libbonoboui-2.2.4
+ >=gnome-base/gail-1
+ !=gnome-extra/libgtkhtml-3.1*"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.30
+ >=dev-util/pkgconfig-0.12.0"
+
+USE_DESTDIR="1"
+SCROLLKEEPER_UPDATE="0"
+ELTCONF="--reverse-deps"
+