summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-21 05:32:01 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-21 05:32:01 +0000
commit1a044cc75761994eaf0970cf05606d4d143d5dda (patch)
treedb45be03dd7000722bc51ccbac76fc145daf59ce /gnome-extra/nautilus-share/nautilus-share-0.7.3-r1.ebuild
parentSorted tree for vlc and nsplugin, and ruby's gtkmozembed, sort profiles accor... (diff)
downloadhistorical-1a044cc75761994eaf0970cf05606d4d143d5dda.tar.gz
historical-1a044cc75761994eaf0970cf05606d4d143d5dda.tar.bz2
historical-1a044cc75761994eaf0970cf05606d4d143d5dda.zip
Add to gnome herd (acked by Maxim), do not install static libraries, add missing build dependencies.
Package-Manager: portage-2.2.0_alpha107/cvs/Linux x86_64
Diffstat (limited to 'gnome-extra/nautilus-share/nautilus-share-0.7.3-r1.ebuild')
-rw-r--r--gnome-extra/nautilus-share/nautilus-share-0.7.3-r1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/gnome-extra/nautilus-share/nautilus-share-0.7.3-r1.ebuild b/gnome-extra/nautilus-share/nautilus-share-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..2398656c5920
--- /dev/null
+++ b/gnome-extra/nautilus-share/nautilus-share-0.7.3-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-share/nautilus-share-0.7.3-r1.ebuild,v 1.1 2012/05/21 05:32:01 tetromino Exp $
+
+EAPI=4
+
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils
+
+DESCRIPTION="A nautilus plugin to easily share folders over the SMB protocol"
+HOMEPAGE="http://gentoo.ovibes.net/nautilus-share http://packages.debian.org/unstable/nautilus-share"
+SRC_URI="mirror://debian/pool/main/n/${PN}/${PN}_${PV}.orig.tar.bz2
+ mirror://debian/pool/main/n/${PN}/${PN}_${PV}-1.debian.tar.gz"
+
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND=">=dev-libs/glib-2.4:2
+ >=gnome-base/nautilus-2.10"
+RDEPEND="${COMMON_DEPEND}
+ net-fs/samba"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+USERSHARES_DIR="/var/lib/samba/usershare"
+USERSHARES_GROUP="samba"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF} --disable-static"
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/debian/patches/15_user-acl.patch
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ keepdir ${USERSHARES_DIR}
+}
+
+pkg_postinst() {
+ enewgroup ${USERSHARES_GROUP}
+ einfo "Fixing ownership and permissions on ${EROOT}${USERSHARES_DIR#/}..."
+ chown root:${USERSHARES_GROUP} "${EROOT}"${USERSHARES_DIR#/}
+ chmod 01770 "${EROOT}"${USERSHARES_DIR#/}
+
+ einfo "To get nautilus-share working, add the lines"
+ einfo
+ einfo " # Allow users in group \"${USERSHARES_GROUP}\" to share"
+ einfo " # directories with the \"net usershare\" commands"
+ einfo " usershare path = \"${EROOT}${USERSHARES_DIR#/}\""
+ einfo " # Set a maximum of 100 user-defined shares in total"
+ einfo " usershare max shares = 100"
+ einfo " # Allow users to permit guest access"
+ einfo " usershare allow guests = yes"
+ einfo " # Only allow users to share directories they own"
+ einfo " usershare owner only = yes"
+ einfo
+ einfo "to the end of the [global] section in /etc/samba/smb.conf."
+ einfo
+ einfo "Users who are to be allowed to use nautilus-share should be added"
+ einfo "to the \"${USERSHARES_GROUP}\" group:"
+ einfo
+ einfo "# gpasswd -a USER ${USERSHARES_GROUP}"
+ einfo
+ einfo "Users may need to log out and in again for the group assignment to"
+ einfo "take effect and to restart Nautilus."
+ einfo
+ einfo "For more information, see USERSHARE in net(8)."
+}